summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Edinaldo P. Silva2018-09-18 00:33:21 +0200
committer David Spencer2018-09-18 00:33:21 +0200
commitde1e7619b22f66981f170d786451d215dff69194 (patch)
treed9eb5df6d1051905a1cf5fa9b9084cc59b55f303 /system
parent5d8e445877424439f87aafbcb45f37571840d5e5 (diff)
downloadslackbuilds-de1e7619b22f66981f170d786451d215dff69194.tar.gz
system/wine-staging: Updated for version 3.16.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/wine-staging/0001-winhlp32-Workaround-a-bug-in-Flex.patch33
-rw-r--r--system/wine-staging/README61
-rw-r--r--system/wine-staging/steam.patch38
-rw-r--r--system/wine-staging/wine-staging.SlackBuild150
-rw-r--r--system/wine-staging/wine-staging.info10
-rw-r--r--system/wine-staging/x86_remove_fpic.patch202
6 files changed, 446 insertions, 48 deletions
diff --git a/system/wine-staging/0001-winhlp32-Workaround-a-bug-in-Flex.patch b/system/wine-staging/0001-winhlp32-Workaround-a-bug-in-Flex.patch
new file mode 100644
index 0000000000..d674ead817
--- /dev/null
+++ b/system/wine-staging/0001-winhlp32-Workaround-a-bug-in-Flex.patch
@@ -0,0 +1,33 @@
+From cf6bdd7b7dc1dc1ba31bd48171c218ba3503eb76 Mon Sep 17 00:00:00 2001
+From: Sebastian Lackner <sebastian@fds-team.de>
+Date: Sat, 14 Jan 2017 05:48:28 +0100
+Subject: winhlp32: Workaround a bug in Flex.
+
+---
+ programs/winhlp32/macro.lex.l | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/programs/winhlp32/macro.lex.l b/programs/winhlp32/macro.lex.l
+index 8f6945ca988..da2dd22e447 100644
+--- a/programs/winhlp32/macro.lex.l
++++ b/programs/winhlp32/macro.lex.l
+@@ -20,7 +20,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA
+ */
+ %}
+-%option noinput nounput never-interactive 8bit
++%option noinput nounput never-interactive 8bit noyywrap
+ %x quote
+ %{
+ #include "config.h"
+@@ -367,7 +367,3 @@ WINHELP_WINDOW* MACRO_CurrentWindow(void)
+ {
+ return lex_data ? lex_data->window : Globals.active_win;
+ }
+-
+-#ifndef yywrap
+-int yywrap(void) { return 1; }
+-#endif
+--
+2.11.0
+
diff --git a/system/wine-staging/README b/system/wine-staging/README
index 56ea72ff4b..973e997edb 100644
--- a/system/wine-staging/README
+++ b/system/wine-staging/README
@@ -9,15 +9,58 @@ before they are integrated into the main branch.
This is a current development branch of Wine appended with full
patches of the Staging branch.
-NOTE: At the moment, it only compiles a 32-bit version of Wine,
-this may change in the future with the ability to compile both
-64-bit and 32-bit versions of Wine. You'll need a full multilib
-system in order to compile this under x86_64 system.
-While this is list as a separate package, this WILL overwrite
-your normal Wine binaries! Please keep this in mind.
+MULTILIB.
-Compile options/optional dependences (keep in mind, you need
-32-bit libs of each):
+With no options this script will build the 32bit wine-staging
+package ONLY!, for which you need to have a FULL multilib
+system installed (see below).
-See README.SLACKWARE for a giant list of dependencies.
+To build a package for both 64bit and 32bit Windows executable
+support, use this:
+
+# WIN64=yes sh wine-staging.SlackBuild
+
+See README.SLACKWARE for a giant list of dependencies and
+AlienBOB's multilib readme and repo:
+
+https://docs.slackware.com/slackware:multilib
+http://www.slackware.com/~alien/multilib/
+
+From wine's maintainer David Woodfall you can grab a script
+to get and install the multilib packages:
+
+http://dawoodfall.net/files/scripts/slackware/alien-multilib-rysnc.sh
+
+Be sure to read the short instructions at the top. If you use
+slackpkg then you will also want to blacklist his packages in
+/etc/slackpkg/blacklist:
+
+[0-9]+alien
+[0-9]+compat32
+
+
+WINEPREFIX.
+
+With 64bit support you would use the wine64 binary. If you have a
+combined 32 and 64bit package you need to set the environmental
+variable WINEPREFIX to point to the 64bit wine directory when running
+wine64, which should be different to the 32bit directory (~/.wine by
+default). Example:
+
+$ WINEPREFIX=~/.wine64 wine64 notepad
+
+To build the 32bit wine on x86_64 you will need to have multilib
+packages installed, unless you want to build for Windows 64 bit
+applications only using:
+
+# WIN64=yes NOWIN32=yes sh wine-staging.SlackBuild
+
+
+OPENGL.
+
+To disable OpenGL support, use:
+
+# OPENGL=no ./wine.SlackBuild
+
+Optional dependencies: fontforge, webcore-fonts, winetricks
diff --git a/system/wine-staging/steam.patch b/system/wine-staging/steam.patch
new file mode 100644
index 0000000000..deef1b5cd8
--- /dev/null
+++ b/system/wine-staging/steam.patch
@@ -0,0 +1,38 @@
+diff --git a/dlls/kernel32/process.c b/dlls/kernel32/process.c
+index 6e7b23e..63eda34 100644
+--- a/dlls/kernel32/process.c
++++ b/dlls/kernel32/process.c
+@@ -2429,6 +2429,33 @@ static BOOL create_process_impl( LPCWSTR app_name, LPWSTR cmd_line, LPSECURITY_A
+ return FALSE;
+ if (hFile == INVALID_HANDLE_VALUE) goto done;
+
++ /* CROSSOVER HACK: bug 13322 (winehq bug 39403)
++ * Insert --no-sandbox in command line of Steam's web helper process to
++ * work around problems hooking our ntdll exports. */
++ {
++ static const WCHAR steamwebhelperexeW[] = {'s','t','e','a','m','w','e','b','h','e','l','p','e','r','.','e','x','e',0};
++ static const WCHAR nosandboxW[] = {' ','-','-','n','o','-','s','a','n','d','b','o','x',0};
++
++ if (strstrW(name, steamwebhelperexeW))
++ {
++ LPWSTR new_command_line;
++
++ new_command_line = HeapAlloc(GetProcessHeap(), 0,
++ sizeof(WCHAR) * (strlenW(tidy_cmdline) + strlenW(nosandboxW) + 1));
++
++ if (!new_command_line) return FALSE;
++
++ strcpyW(new_command_line, tidy_cmdline);
++ strcatW(new_command_line, nosandboxW);
++
++ TRACE("CrossOver hack changing command line to %s\n", debugstr_w(new_command_line));
++
++ if (tidy_cmdline != cmd_line) HeapFree( GetProcessHeap(), 0, tidy_cmdline );
++ tidy_cmdline = new_command_line;
++ }
++ }
++ /* end CROSSOVER HACK */
++
+ /* Warn if unsupported features are used */
+
+ if (flags & (IDLE_PRIORITY_CLASS | HIGH_PRIORITY_CLASS | REALTIME_PRIORITY_CLASS |
diff --git a/system/wine-staging/wine-staging.SlackBuild b/system/wine-staging/wine-staging.SlackBuild
index e35bb496c8..668e6efc63 100644
--- a/system/wine-staging/wine-staging.SlackBuild
+++ b/system/wine-staging/wine-staging.SlackBuild
@@ -30,7 +30,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wine-staging
-VERSION=${VERSION:-3.15}
+VERSION=${VERSION:-3.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,29 +49,53 @@ OUTPUT=${OUTPUT:-/tmp}
# If your video card does not support hardware accelerated OpenGL,
# run the script like: OPENGL=NO ./wine.SlackBuild
-OPENGL=${OPENGL:-YES}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX=""
+if [ "${OPENGL:-YES}" = "YES" ]; then
+ do_opengl="with"
else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
+ do_opengl="without"
fi
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+if [ -n "$NOWIN32" ] && [ -z "$WIN64" ]; then
+ echo "Both 64 and 32 bit builds disabled. Nothing to do."
+ exit 1
+fi
+
+# These should work for anything not specified below
+BUILD_ARCH=$ARCH"-slackware-linux"
+SLKCFLAGS="-O2"
+
+case "$ARCH" in
+ arm)
+ BUILD_ARCH=$ARCH"-slackware-linux-gnueabi"
+ ;;
+ i?86)
+ # -Os was -O2, fix for:
+ # https://bugs.winehq.org/show_bug.cgi?id=42406
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78911
+ # https://bugs.gentoo.org/613128
+ SLKCFLAGS="-Os -march=$ARCH -mtune=i686"
+ ;;
+ x86_64)
+ [ -n "$WIN64" ] && WIN64="--enable-win64"
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ ;;
+esac
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-rm -rf wine-$VERSION
+rm -rf $PRGNAM-$VERSION wine-$VERSION
tar xvf $CWD/wine-$VERSION.tar.xz
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
@@ -93,29 +117,87 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# from Arch Linux PKGBUILD.
+# Fix for flex.
+patch -p1 --verbose < $CWD/0001-winhlp32-Workaround-a-bug-in-Flex.patch
+
+# freetype harmony fix.
patch -Np1 < $CWD/harmony-fix.diff
+
+# fix path of opencl headers.
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
-# If OPENGL=YES above, then enable opengl; otherwise, disable it.
-if [ "$OPENGL" = "YES" ]; then
- do_opengl="with"
- else
- do_opengl="without"
+# Steam crossover hack for store/web functionality.
+# https://bugs.winehq.org/show_bug.cgi?id=39403
+patch -Np1 < $CWD/steam.patch
+
+# Remove -fPIC for i?86 or the build will hang.
+if [ "$ARCH" == "i?86" ]; then
+ patch -p1 --verbose < $CWD/x86_remove_fpic.patch
fi
-./configure \
- --prefix=/usr \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --with-gnutls=yes \
- --${do_opengl}-opengl \
- --build=$ARCH-slackware-linux
-
-NUMJOBS=${NUMJOBS:-"-s -j6 -l7"}
-make $NUMJOBS || exit 1
-#make
-make install DESTDIR=$PKG
+if [ -n "$WIN64" ]; then
+ wine64="--with-wine64=../wine64"
+ mkdir wine64
+ cd wine64
+
+ LDFLAGS="-L/usr/lib64 -ldl" \
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ../configure \
+ --enable-win64 \
+ --prefix=/usr \
+ --libdir=/usr/lib64 \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --mandir=/usr/man \
+ --with-x \
+ --with-gnutls \
+ --${do_opengl}-opengl \
+ --program-prefix= \
+ --program-suffix= \
+ --disable-tests \
+ --build=$BUILD_ARCH
+
+ make depend
+ make
+ #NUMJOBS=${NUMJOBS:-"-s -j6 -l7"}
+ #make $NUMJOBS || exit 1
+ make install DESTDIR=$PKG
+ cd ..
+fi
+
+
+if [ -z "$NOWIN32" ]; then
+ mkdir wine32
+ cd wine32
+
+ export PKG_CONFIG_PATH="/usr/lib/pkgconfig:$PKG_CONFIG_PATH"
+
+ LDFLAGS="-L/usr/lib -ldl" \
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ../configure \
+ $wine64 \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --mandir=/usr/man \
+ --with-x \
+ --with-gnutls \
+ --${do_opengl}-opengl \
+ --program-prefix= \
+ --program-suffix= \
+ --disable-tests \
+ --build=$BUILD_ARCH
+
+ make depend
+ make
+ #NUMJOBS=${NUMJOBS:-"-s -j6 -l7"}
+ #make $NUMJOBS || exit 1
+ make install DESTDIR=$PKG
+ cd ..
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/system/wine-staging/wine-staging.info b/system/wine-staging/wine-staging.info
index 42f879cdef..681409fab4 100644
--- a/system/wine-staging/wine-staging.info
+++ b/system/wine-staging/wine-staging.info
@@ -1,10 +1,10 @@
PRGNAM="wine-staging"
-VERSION="3.15"
+VERSION="3.16"
HOMEPAGE="https://wiki.winehq.org/Wine-Staging"
-DOWNLOAD="https://dl.winehq.org/wine/source/3.x/wine-3.15.tar.xz \
- https://github.com/wine-staging/wine-staging/archive/v3.15/wine-staging-3.15.tar.gz"
-MD5SUM="b6fd6fbd08c1ff4599575ca5784bf920 \
- d1382d2f605503ab2cef8dc034987af6"
+DOWNLOAD="https://dl.winehq.org/wine/source/3.x/wine-3.16.tar.xz \
+ https://github.com/wine-staging/wine-staging/archive/v3.16/wine-staging-3.16.tar.gz"
+MD5SUM="cee2fe3cd14368b32285d2a0d719f015 \
+ a0055275be492848c948e8a5250e4274"
DOWNLOAD_x86_64="UNSUPPORTED"
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/wine-staging/x86_remove_fpic.patch b/system/wine-staging/x86_remove_fpic.patch
new file mode 100644
index 0000000000..ac949dc86d
--- /dev/null
+++ b/system/wine-staging/x86_remove_fpic.patch
@@ -0,0 +1,202 @@
+diff -Naur a/configure b/configure
+--- a/configure 2018-01-02 20:58:13.000000000 +0000
++++ b/configure 2018-01-08 18:31:55.480995247 +0000
+@@ -8072,7 +8072,7 @@
+ done
+
+ LIBEXT="dylib"
+- DLLFLAGS="$DLLFLAGS -fPIC"
++ DLLFLAGS="$DLLFLAGS "
+ LDRPATH_INSTALL="-Wl,-rpath,@loader_path/\`\$(MAKEDEP) -R \${bindir} \${libdir}\`"
+ LDRPATH_LOCAL="-Wl,-rpath,@loader_path/\$(top_builddir)/libs/wine"
+ COREFOUNDATION_LIBS="-framework CoreFoundation"
+@@ -8304,14 +8304,14 @@
+ ;;
+
+ linux-android*)
+- DLLFLAGS="$DLLFLAGS -fPIC"
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -Wl,--export-dynamic" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -Wl,--export-dynamic... " >&6; }
++ DLLFLAGS="$DLLFLAGS "
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -Wl,--export-dynamic" >&5
++$as_echo_n "checking whether the compiler supports -Wl,--export-dynamic... " >&6; }
+ if ${ac_cv_cflags__fPIC__Wl___export_dynamic+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -Wl,--export-dynamic"
++CFLAGS="$CFLAGS -Wl,--export-dynamic"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8330,14 +8330,14 @@
+ if test "x$ac_cv_cflags__fPIC__Wl___export_dynamic" = xyes; then :
+ LDEXECFLAGS="-Wl,--export-dynamic"
+ fi
+- as_ac_var=`$as_echo "ac_cv_cflags_-fPIC -Wl,--rpath,\\$ORIGIN/../lib" | $as_tr_sh`
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib... " >&6; }
++ as_ac_var=`$as_echo "ac_cv_cflags_ -Wl,--rpath,\\$ORIGIN/../lib" | $as_tr_sh`
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -Wl,--rpath,\$ORIGIN/../lib" >&5
++$as_echo_n "checking whether the compiler supports -Wl,--rpath,\$ORIGIN/../lib... " >&6; }
+ if eval \${$as_ac_var+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -Wl,--rpath,\$ORIGIN/../lib"
++CFLAGS="$CFLAGS -Wl,--rpath,\$ORIGIN/../lib"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8358,14 +8358,14 @@
+ LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(MAKEDEP) -R \${bindir} \${libdir}\`"
+ LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(top_builddir)/libs/wine"
+ else
+- as_ac_var=`$as_echo "ac_cv_cflags_-fPIC -Wl,-R,\\$ORIGIN/../lib" | $as_tr_sh`
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib... " >&6; }
++ as_ac_var=`$as_echo "ac_cv_cflags_ -Wl,-R,\\$ORIGIN/../lib" | $as_tr_sh`
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -Wl,-R,\$ORIGIN/../lib" >&5
++$as_echo_n "checking whether the compiler supports -Wl,-R,\$ORIGIN/../lib... " >&6; }
+ if eval \${$as_ac_var+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -Wl,-R,\$ORIGIN/../lib"
++CFLAGS="$CFLAGS -Wl,-R,\$ORIGIN/../lib"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8448,7 +8448,7 @@
+ ;;
+
+ *)
+- DLLFLAGS="$DLLFLAGS -fPIC"
++ DLLFLAGS="$DLLFLAGS "
+ LDEXECFLAGS=""
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether we can build a GNU style ELF dll" >&5
+ $as_echo_n "checking whether we can build a GNU style ELF dll... " >&6; }
+@@ -8456,7 +8456,7 @@
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -shared -Wl,-Bsymbolic"
++CFLAGS="$CFLAGS -shared -Wl,-Bsymbolic"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ void myfunc() {}
+@@ -8475,13 +8475,13 @@
+ if test "$ac_cv_c_dll_gnuelf" = "yes"
+ then
+ LIBWINE_LDFLAGS="-shared"
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -shared -Wl,-soname,confest.so.1" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -shared -Wl,-soname,confest.so.1... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -shared -Wl,-soname,confest.so.1" >&5
++$as_echo_n "checking whether the compiler supports -shared -Wl,-soname,confest.so.1... " >&6; }
+ if ${ac_cv_cflags__fPIC__shared__Wl__soname_confest_so_1+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -shared -Wl,-soname,confest.so.1"
++CFLAGS="$CFLAGS -shared -Wl,-soname,confest.so.1"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8500,13 +8500,13 @@
+ if test "x$ac_cv_cflags__fPIC__shared__Wl__soname_confest_so_1" = xyes; then :
+ LIBWINE_LDFLAGS="-shared -Wl,-soname,libwine.so.$libwine_soversion"
+ else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -shared -Wl,-h,confest.so.1" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -shared -Wl,-h,confest.so.1... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -shared -Wl,-h,confest.so.1" >&5
++$as_echo_n "checking whether the compiler supports -shared -Wl,-h,confest.so.1... " >&6; }
+ if ${ac_cv_cflags__fPIC__shared__Wl__h_confest_so_1+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -shared -Wl,-h,confest.so.1"
++CFLAGS="$CFLAGS -shared -Wl,-h,confest.so.1"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8528,13 +8528,13 @@
+ fi
+
+ echo '{ global: *; };' >conftest.map
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -shared -Wl,--version-script=conftest.map" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -shared -Wl,--version-script=conftest.map... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -shared -Wl,--version-script=conftest.map" >&5
++$as_echo_n "checking whether the compiler supports -shared -Wl,--version-script=conftest.map... " >&6; }
+ if ${ac_cv_cflags__fPIC__shared__Wl___version_script_conftest_map+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -shared -Wl,--version-script=conftest.map"
++CFLAGS="$CFLAGS -shared -Wl,--version-script=conftest.map"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8555,13 +8555,13 @@
+ fi
+ rm -f conftest.map
+
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -Wl,--export-dynamic" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -Wl,--export-dynamic... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -Wl,--export-dynamic" >&5
++$as_echo_n "checking whether the compiler supports -Wl,--export-dynamic... " >&6; }
+ if ${ac_cv_cflags__fPIC__Wl___export_dynamic+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -Wl,--export-dynamic"
++CFLAGS="$CFLAGS -Wl,--export-dynamic"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8581,14 +8581,14 @@
+ LDEXECFLAGS="-Wl,--export-dynamic"
+ fi
+
+- as_ac_var=`$as_echo "ac_cv_cflags_-fPIC -Wl,--rpath,\\$ORIGIN/../lib" | $as_tr_sh`
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib... " >&6; }
++ as_ac_var=`$as_echo "ac_cv_cflags_ -Wl,--rpath,\\$ORIGIN/../lib" | $as_tr_sh`
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -Wl,--rpath,\$ORIGIN/../lib" >&5
++$as_echo_n "checking whether the compiler supports -Wl,--rpath,\$ORIGIN/../lib... " >&6; }
+ if eval \${$as_ac_var+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -Wl,--rpath,\$ORIGIN/../lib"
++CFLAGS="$CFLAGS -Wl,--rpath,\$ORIGIN/../lib"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8609,14 +8609,14 @@
+ LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(MAKEDEP) -R \${bindir} \${libdir}\`"
+ LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(top_builddir)/libs/wine"
+ else
+- as_ac_var=`$as_echo "ac_cv_cflags_-fPIC -Wl,-R,\\$ORIGIN/../lib" | $as_tr_sh`
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib" >&5
+-$as_echo_n "checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib... " >&6; }
++ as_ac_var=`$as_echo "ac_cv_cflags_ -Wl,-R,\\$ORIGIN/../lib" | $as_tr_sh`
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -Wl,-R,\$ORIGIN/../lib" >&5
++$as_echo_n "checking whether the compiler supports -Wl,-R,\$ORIGIN/../lib... " >&6; }
+ if eval \${$as_ac_var+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -Wl,-R,\$ORIGIN/../lib"
++CFLAGS="$CFLAGS -Wl,-R,\$ORIGIN/../lib"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ int main(int argc, char **argv) { return 0; }
+@@ -8804,7 +8804,7 @@
+ $as_echo_n "(cached) " >&6
+ else
+ ac_wine_try_cflags_saved=$CFLAGS
+-CFLAGS="$CFLAGS -fPIC -Wl,-G,-h,conftest.so.1.0,-B,symbolic"
++CFLAGS="$CFLAGS -Wl,-G,-h,conftest.so.1.0,-B,symbolic"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ void myfunc() {}