summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Cristiano Urban2019-10-05 00:25:58 +0200
committer Willy Sudiarto Raharjo2019-10-05 00:25:58 +0200
commit304c3b674b76ba89b1b816d6a20f2b7302462c59 (patch)
tree57ba171d267f44eb7c0c2468ef978446c3796225 /system
parentfc0cb2b5f2f3c64c3f841230fc0a1adde60d30b4 (diff)
downloadslackbuilds-304c3b674b76ba89b1b816d6a20f2b7302462c59.tar.gz
system/I-Nex: Fix build.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/I-Nex/I-Nex.SlackBuild2
-rw-r--r--system/I-Nex/I-Nex_fix.patch23
2 files changed, 25 insertions, 0 deletions
diff --git a/system/I-Nex/I-Nex.SlackBuild b/system/I-Nex/I-Nex.SlackBuild
index cccc0974f2..a094087108 100644
--- a/system/I-Nex/I-Nex.SlackBuild
+++ b/system/I-Nex/I-Nex.SlackBuild
@@ -72,6 +72,8 @@ find -L . \
sed -i 's|python3$|python2|' pastebinit
sed -i -e 's|^STATIC.*|STATIC = false|' i-nex.mk
+patch -p1 -i $CWD/I-Nex_fix.patch
+
cd $PRGNAM
autoreconf --install
diff --git a/system/I-Nex/I-Nex_fix.patch b/system/I-Nex/I-Nex_fix.patch
new file mode 100644
index 0000000000..bdf439f84f
--- /dev/null
+++ b/system/I-Nex/I-Nex_fix.patch
@@ -0,0 +1,23 @@
+--- a/I-Nex/i-nex/.src/Finfosys.class 2019-09-28 17:03:37.613473723 +0200
++++ b/I-Nex/i-nex/.src/Finfosys.class 2019-09-28 17:04:45.017472516 +0200
+@@ -322,6 +322,7 @@
+ Public Sub System()
+ Dim hostname, arch, gcc, timezone, xorg_version, glx_version As String
+ Dim SCREENFETCH_P As Process
++ Dim sLine2 As String
+ SCREENFETCH_P = Exec ["" & ChkPrm.ChkExecDir("bash") & ""] For Write
+ Write #SCREENFETCH_P, File.Load("Data/screenfetch-dev")
+ SCREENFETCH_P.Wait
+@@ -332,9 +333,9 @@
+ Shell "timedatectl status | grep \"Time zone:\" | cut -d \":\" -f 2 | cut -d \"(\" -f 1" Wait To timezone
+ Endif
+ 'Detect heap size
+- For Each sLine In Split(File.Load("/proc/self/maps"), "\n")
+- If InStr(sLine, "[heap]") Then
+- aScan = Scan(sLine, "*-* *")
++ For Each sLine2 In Split(File.Load("/proc/self/maps"), "\n")
++ If InStr(sLine2, "[heap]") Then
++ aScan = Scan(sLine2, "*-* *")
+ Label176.Text = "Heap size is " & Format(Val("&H" & aScan[1] & "&") - Val("&H" & aScan[0] & "&"), "#,##0") & " bytes."
+ Break
+ Endif