summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Zhu Qun-Ying2017-02-10 00:40:46 +0100
committer Willy Sudiarto Raharjo2017-02-11 01:24:33 +0100
commit333be072ab504f761eacf94d54c875bd41aa4133 (patch)
treeb3aa3604b32a4335a09c27903f15d2f43f2280a3 /system
parent7272fbf45e83a94f0b532e6fb9ab0dc7c5b83fea (diff)
downloadslackbuilds-333be072ab504f761eacf94d54c875bd41aa4133.tar.gz
system/hh: Updated for version 1.22.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/hh/README9
-rw-r--r--system/hh/configure.patch11
-rw-r--r--system/hh/hh.SlackBuild21
-rw-r--r--system/hh/hh.info6
-rw-r--r--system/hh/slack-desc6
5 files changed, 36 insertions, 17 deletions
diff --git a/system/hh/README b/system/hh/README
index 11f05deca8..7a0586e4fd 100644
--- a/system/hh/README
+++ b/system/hh/README
@@ -1,3 +1,6 @@
-BASH history suggest box is a command line utility which brings
-improved BASH command completion from the history. It aims to
-make completion easier to use and more efficient than Ctrl-r.
+Bash and Zsh shell history suggest box - easily view, navigate, search and
+manage your command history.
+
+It is a command line utility which brings improved command completion from
+the history. It aims to make completion easier to use and more efficient
+ than Ctrl-r.
diff --git a/system/hh/configure.patch b/system/hh/configure.patch
new file mode 100644
index 0000000000..6560442f43
--- /dev/null
+++ b/system/hh/configure.patch
@@ -0,0 +1,11 @@
+--- hstr-1.22/configure.ac 2017-02-02 12:44:38.000000000 -0800
++++ hstr-1.22.new/configure.ac 2017-02-09 14:26:56.524105894 -0800
+@@ -49,7 +49,7 @@
+
+ # Checks for libraries.
+ AC_CHECK_LIB(m, cos, [], [AC_MSG_ERROR([Could not find m library])])
+-AC_CHECK_LIB(readline, using_history, [], [AC_MSG_ERROR([Could not find readline library])])
++AC_CHECK_LIB(readline, using_history, [], [AC_MSG_ERROR([Could not find readline library])],[-lncurses])
+
+ # Checks for header files.
+ AC_CHECK_HEADER(assert.h)
diff --git a/system/hh/hh.SlackBuild b/system/hh/hh.SlackBuild
index 1f1d9b3a2e..866112bd11 100644
--- a/system/hh/hh.SlackBuild
+++ b/system/hh/hh.SlackBuild
@@ -23,13 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=hh
-VERSION=${VERSION:-1.15}
+VERSION=${VERSION:-1.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGNAM=hstr
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,10 +60,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION-src.tgz
-cd hstr
-#cp $CWD/autogen.sh .
+rm -rf $PKGNAM-$VERSION
+tar xvf $CWD/$PKGNAM-$VERSION.tar.gz
+cd $PKGNAM-$VERSION
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -70,8 +71,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/configure.patch
+autoreconf -vis
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
+ac_cv_func_malloc_0_nonnull=yes \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
diff --git a/system/hh/hh.info b/system/hh/hh.info
index 2d951a5848..76e8633277 100644
--- a/system/hh/hh.info
+++ b/system/hh/hh.info
@@ -1,8 +1,8 @@
PRGNAM="hh"
-VERSION="1.15"
+VERSION="1.22"
HOMEPAGE="https://github.com/dvorka/hstr"
-DOWNLOAD="https://github.com/dvorka/hstr/releases/download/1.15/hh-1.15-src.tgz"
-MD5SUM="0278e311af900246817af1ccbd4e48b6"
+DOWNLOAD="https://github.com/dvorka/hstr/archive/1.22/hstr-1.22.tar.gz"
+MD5SUM="620dab922fadf2858938fbe36d9f99fd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/hh/slack-desc b/system/hh/slack-desc
index fa4f327f24..29a7bd1aa6 100644
--- a/system/hh/slack-desc
+++ b/system/hh/slack-desc
@@ -6,10 +6,10 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-hh: hh (BASH History Suggest Box)
+hh: hh (BASH and Zsh Shell History Suggest Box)
hh:
-hh: BASH history suggest box is a command line utility that brings
-hh: improved BASH command completion from the history. It aims to
+hh: BASH and Zsh Shell history suggest box is a command line utility that
+hh: brings improved command completion from the history. It aims to
hh: make completion easier and more efficient than Ctrl-r.
hh:
hh: