summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Roberto Neri2013-06-03 08:40:16 +0200
committer Robby Workman2013-06-04 07:11:31 +0200
commit0906e339632641432bb1f1e2aecee6c6e69480a4 (patch)
tree7a85e75460e1cec06160c8a4f96e463d9f58b419 /system
parentc27f41749625483c50e1befd9ec467c7036bfd96 (diff)
downloadslackbuilds-0906e339632641432bb1f1e2aecee6c6e69480a4.tar.gz
system/rodent: Updated for version 5.0.3.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/rodent/rodent-4.8.0.diff22
-rw-r--r--system/rodent/rodent.SlackBuild29
-rw-r--r--system/rodent/rodent.info6
3 files changed, 15 insertions, 42 deletions
diff --git a/system/rodent/rodent-4.8.0.diff b/system/rodent/rodent-4.8.0.diff
deleted file mode 100644
index b5f2b1698f..0000000000
--- a/system/rodent/rodent-4.8.0.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ur rodent-4.8.0.orig//Build/plugins/Makefile.am rodent-4.8.0/Build/plugins/Makefile.am
---- rodent-4.8.0.orig//Build/plugins/Makefile.am 2012-06-25 15:49:48.000000000 +0200
-+++ rodent-4.8.0/Build/plugins/Makefile.am 2012-06-28 11:32:27.775686892 +0200
-@@ -239,5 +239,5 @@
-
- if WANT_EXPERIMENTAL
- install-exec-local:
-- $(top_srcdir)/install-sh $(dirplug)/filesystem_user_space/rfm-simple-agent $(bindir)
-+ $(top_srcdir)/install-sh $(dirplug)/filesystem_user_space/rfm-simple-agent $(DESTDIR)$(bindir)
- endif
-diff -ur rodent-4.8.0.orig//Build/plugins/Makefile.in rodent-4.8.0/Build/plugins/Makefile.in
---- rodent-4.8.0.orig//Build/plugins/Makefile.in 2012-06-27 21:39:52.000000000 +0200
-+++ rodent-4.8.0/Build/plugins/Makefile.in 2012-06-28 11:46:03.518488703 +0200
-@@ -1326,7 +1326,7 @@
- )
-
- @WANT_EXPERIMENTAL_TRUE@install-exec-local:
--@WANT_EXPERIMENTAL_TRUE@ $(top_srcdir)/install-sh $(dirplug)/filesystem_user_space/rfm-simple-agent $(bindir)
-+@WANT_EXPERIMENTAL_TRUE@ $(top_srcdir)/install-sh $(dirplug)/filesystem_user_space/rfm-simple-agent $(DESTDIR)$(bindir)
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/system/rodent/rodent.SlackBuild b/system/rodent/rodent.SlackBuild
index 098e482997..214294b9a1 100644
--- a/system/rodent/rodent.SlackBuild
+++ b/system/rodent/rodent.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for rodent
-# Copyright 2011-2012 Roberto Neri, Palermo, Italy
+# Copyright 2011-2013 Roberto Neri, Palermo, Italy
#
# All rights reserved.
#
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=rodent
-VERSION=${VERSION:-4.8.0}
+VERSION=${VERSION:-5.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,7 +57,11 @@ fi
# The experimental plugins are disabled by default but can be enabled
# by passing EXPERIMENTAL=yes to the script
-EXPERIMENTAL=${EXPERIMENTAL:-no}
+if [ "${EXPERIMENTAL:-no}" = "yes" ]; then
+ ENABLE_EXPERIMENTAL="enable"
+else
+ ENABLE_EXPERIMENTAL="disable"
+fi
set -e
@@ -74,9 +78,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix Build/plugins/Makefile
-patch -p1 < $CWD/$PRGNAM-$VERSION.diff
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -84,19 +85,14 @@ CXXFLAGS="$SLKCFLAGS" \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-experimental=$EXPERIMENTAL \
+ --$ENABLE_EXPERIMENTAL-experimental \
--build=$ARCH-slackware-linux
make
-
-# Note: the manual (RTFM.pdf) is installed in /usr/share/doc/rfm-Delta
-# This could be overridden by passing docdir=/usr/doc/$PRGNAM-$VERSION
-# to "make install", but that would break the "Help" function, so it's
-# better to leave it in its non-standard location
-# =========
-# Yes, but that's a bug. Edscott should fix that. :)
-# --rworkman
-make install DESTDIR=$PKG
+# Install the manual (RTFM.pdf) in the standard Slackware location...
+make install DESTDIR=$PKG rtfmdir=/usr/doc/$PRGNAM-$VERSION
+# ...and create a symlink so it can be opened by the Help function
+( cd $PKG/usr/doc ; ln -sf $PRGNAM-$VERSION rfm )
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -104,7 +100,6 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS ChangeLog COPYING INSTALL NEWS README TODO WISHLIST \
$PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/system/rodent/rodent.info b/system/rodent/rodent.info
index 3e398cb8f8..6ec4d80230 100644
--- a/system/rodent/rodent.info
+++ b/system/rodent/rodent.info
@@ -1,8 +1,8 @@
PRGNAM="rodent"
-VERSION="4.8.0"
+VERSION="5.0.3"
HOMEPAGE="http://rodent.xffm.org/"
-DOWNLOAD="http://downloads.sourceforge.net/xffm/rodent-4.8.0.tar.bz2"
-MD5SUM="2f42f93d73be3e1321685b2752e64934"
+DOWNLOAD="http://downloads.sourceforge.net/xffm/rodent-5.0.3.tar.bz2"
+MD5SUM="538f5323f871e939774fc1b9d6683ad9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""