summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Marcel Saegebarth2013-01-01 06:31:52 +0100
committer dsomero2013-01-01 06:39:16 +0100
commitc55dadbd64611ecbfc9274b191bcb4191616abcb (patch)
tree7288c8e91d9a5db0a9aec2a0027c6ffdad1bdbfb /system
parent172d58e8fa6195db10f680ea689f9b366f0eb796 (diff)
downloadslackbuilds-c55dadbd64611ecbfc9274b191bcb4191616abcb.tar.gz
system/fs-uae: Added (Amiga Emulator)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/fs-uae/README4
-rw-r--r--system/fs-uae/doinst.sh9
-rw-r--r--system/fs-uae/fs-uae-launcher.desktop10
-rw-r--r--system/fs-uae/fs-uae.SlackBuild89
-rw-r--r--system/fs-uae/fs-uae.info10
-rw-r--r--system/fs-uae/slack-desc19
6 files changed, 141 insertions, 0 deletions
diff --git a/system/fs-uae/README b/system/fs-uae/README
new file mode 100644
index 0000000000..02d4c3c166
--- /dev/null
+++ b/system/fs-uae/README
@@ -0,0 +1,4 @@
+FS-UAE focuses on emulating Amiga games using the accurate emulation code
+from WinUAE. It also has features to emulate a high-end Amiga with expansions.
+
+Optionally `distribute` can be used instead of `pysetuptools`. \ No newline at end of file
diff --git a/system/fs-uae/doinst.sh b/system/fs-uae/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/system/fs-uae/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/fs-uae/fs-uae-launcher.desktop b/system/fs-uae/fs-uae-launcher.desktop
new file mode 100644
index 0000000000..be33def7ae
--- /dev/null
+++ b/system/fs-uae/fs-uae-launcher.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=FS-UAE Launcher
+Comment=FS-UAE Amiga Emulator
+TryExec=fs-uae-launcher
+Exec=fs-uae-launcher
+StartupNotify=true
+Terminal=false
+Type=Application
+Icon=fs-uae
+Categories=System;Emulator;
diff --git a/system/fs-uae/fs-uae.SlackBuild b/system/fs-uae/fs-uae.SlackBuild
new file mode 100644
index 0000000000..fdec0d0459
--- /dev/null
+++ b/system/fs-uae/fs-uae.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# SlackBuild script for "fs-uae".
+
+# Copyright 2012 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fs-uae
+VERSION=2.0.1
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+make CXXFLAGS="$SLKCFLAGS"
+make install prefix=$PKG/usr docdir=$PKG/usr/doc/$PRGNAM-$VERSION
+
+cd launcher
+ python setup.py install --root=$PKG
+cd ..
+
+install -D -m 0644 $CWD/fs-uae-launcher.desktop $PKG/usr/share/applications
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/fs-uae/fs-uae.info b/system/fs-uae/fs-uae.info
new file mode 100644
index 0000000000..87035d3e28
--- /dev/null
+++ b/system/fs-uae/fs-uae.info
@@ -0,0 +1,10 @@
+PRGNAM="fs-uae"
+VERSION="2.0.1"
+HOMEPAGE="http://fengestad.no/fs-uae/"
+DOWNLOAD="http://fengestad.no/fs-uae/stable/2.0.1/fs-uae-2.0.1.tar.gz"
+MD5SUM="520fca705aab141c258bbd89d83c5600"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="OpenAL wxPython pysetuptools pygame"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/system/fs-uae/slack-desc b/system/fs-uae/slack-desc
new file mode 100644
index 0000000000..ea9de457c0
--- /dev/null
+++ b/system/fs-uae/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fs-uae: FS-UAE (Amiga Emulator)
+fs-uae:
+fs-uae: FS-UAE focuses on emulating Amiga games using the accurate emulation
+fs-uae: code from WinUAE. It also has features to emulate a high-end Amiga
+fs-uae: with expansions.
+fs-uae:
+fs-uae: Homepage: http://fengestad.no/fs-uae/
+fs-uae:
+fs-uae:
+fs-uae:
+fs-uae: