summaryrefslogtreecommitdiffstats
path: root/system/vinterm/vinterm.SlackBuild
diff options
context:
space:
mode:
author B. Watson2017-03-04 09:19:45 +0100
committer Willy Sudiarto Raharjo2017-03-05 05:29:50 +0100
commitc2137dda00a00d69cdb725f63851a298d9a93a0b (patch)
treebde0b68bf3ed0d1c905798ce5ab76582a9adb5a6 /system/vinterm/vinterm.SlackBuild
parent81f58e6dc32211c15cca5e72659d1f9c713eeb58 (diff)
downloadslackbuilds-c2137dda00a00d69cdb725f63851a298d9a93a0b.tar.gz
system/vinterm: Fix icon/desktop installation.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/vinterm/vinterm.SlackBuild')
-rw-r--r--system/vinterm/vinterm.SlackBuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/system/vinterm/vinterm.SlackBuild b/system/vinterm/vinterm.SlackBuild
index 25e9bb3506..0bf689559d 100644
--- a/system/vinterm/vinterm.SlackBuild
+++ b/system/vinterm/vinterm.SlackBuild
@@ -6,9 +6,14 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20170304 bkw:
+# - BUILD=2
+# - include icons/desktop in the package instead of spamming them
+# to /usr (!)
+
PRGNAM=vinterm
VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,6 +60,9 @@ find -L . \
sed -i -e "s,-Os,$SLKCFLAGS," -e "s,usr/lib,usr/lib$LIBDIRSUFFIX," config.mk
+# GRR. "make install" respects DESTDIR... except for the icons and .desktop.
+patch -p1 < $CWD/fix_destdir.diff
+
export TERMINFO=$PKG/usr/share/terminfo
mkdir -p $TERMINFO
make all install DEBUG=no DESTDIR=$PKG PREFIX=/usr MANPREFIX=/usr/man
@@ -62,8 +70,7 @@ make all install DEBUG=no DESTDIR=$PKG PREFIX=/usr MANPREFIX=/usr/man
# exe already stripped
gzip $PKG/usr/man/man1/$PRGNAM.1
-mkdir -p $PKG/usr/share/applications
-ln -s ../$PRGNAM/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+ln -sf ../$PRGNAM/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/share/pixmaps
cat icon/icon_128.png > $PKG/usr/share/pixmaps/$PRGNAM.png