summaryrefslogtreecommitdiffstats
path: root/system/sysdig/sysdig.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2016-08-14 20:38:27 +0200
committer Willy Sudiarto Raharjo2016-08-20 02:51:32 +0200
commitb466c46292da79c42216919e2269fde2d944611c (patch)
tree3991ff286641d4fdbbdb3246a6451aaef8c99870 /system/sysdig/sysdig.SlackBuild
parent62217ef9174a4d6d4666278ed8d3dfb303625148 (diff)
downloadslackbuilds-b466c46292da79c42216919e2269fde2d944611c.tar.gz
system/sysdig: Updated for version 0.11.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'system/sysdig/sysdig.SlackBuild')
-rw-r--r--system/sysdig/sysdig.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/system/sysdig/sysdig.SlackBuild b/system/sysdig/sysdig.SlackBuild
index c01cac54db..a7f9d85a77 100644
--- a/system/sysdig/sysdig.SlackBuild
+++ b/system/sysdig/sysdig.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sysdig
-# Copyright 2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2015-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sysdig
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,7 +62,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz 2>/dev/null || tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -82,6 +82,10 @@ else
sed -i '/sysdig-probe-loader/,$d' scripts/CMakeLists.txt
fi
+# Fix using jq private headers.
+# Source: https://github.com/draios/sysdig/issues/626
+patch -p1 < $CWD/0.11.0-do-not-use-private-jq-api.patch
+
mkdir build
cd build
cmake -G "Unix Makefiles" \