summaryrefslogtreecommitdiffstats
path: root/system/slim/CMakeLists.txt.patch
diff options
context:
space:
mode:
author Ryan P.C. McQuen2014-08-10 19:08:49 +0200
committer Willy Sudiarto Raharjo2014-08-15 18:21:21 +0200
commit1916c02cb6af9777f0ff40fd9192ef1d5b977b04 (patch)
tree15c213ed3f8615468c42dabc027efcd1aeae4ade /system/slim/CMakeLists.txt.patch
parent48e3666c679d5b0411c52ec7d7648a7ebc714217 (diff)
downloadslackbuilds-1916c02cb6af9777f0ff40fd9192ef1d5b977b04.tar.gz
system/slim: Updated for version 1.3.6 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/slim/CMakeLists.txt.patch')
-rw-r--r--system/slim/CMakeLists.txt.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/slim/CMakeLists.txt.patch b/system/slim/CMakeLists.txt.patch
new file mode 100644
index 0000000000..9a29e6c2d7
--- /dev/null
+++ b/system/slim/CMakeLists.txt.patch
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2014-08-08 07:24:01.864876514 -0700
++++ CMakeLists.txt 2014-08-08 07:24:51.980873088 -0700
+@@ -221,7 +221,10 @@
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
++## we have to comment this out or else
++## build will fail on slackware as pam
++## is required for slimlock
++#install(TARGETS slimlock RUNTIME DESTINATION bin)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES