summaryrefslogtreecommitdiffstats
path: root/system/newLd
diff options
context:
space:
mode:
author B. Watson2022-02-10 19:39:38 +0100
committer Willy Sudiarto Raharjo2022-02-12 07:32:48 +0100
commitdeb357124fa74aa6da71431a1773489f50205022 (patch)
tree4db36e368455490cedc903bc84546cab2e702c29 /system/newLd
parentd25f4ebbd13e19005a42736fcade3bb723504f5f (diff)
downloadslackbuilds-deb357124fa74aa6da71431a1773489f50205022.tar.gz
system/newLd: Fix build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/newLd')
-rw-r--r--system/newLd/newLd.SlackBuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/system/newLd/newLd.SlackBuild b/system/newLd/newLd.SlackBuild
index 6326092a67..26698158f8 100644
--- a/system/newLd/newLd.SlackBuild
+++ b/system/newLd/newLd.SlackBuild
@@ -24,6 +24,7 @@
# Adapted by Jan F. Chadima <jfch@jagda.eu> for use as slackport in Slackware 14.2
+# 20220210 bkw: Modified by SlackBuilds.org: fix build.
cd $(dirname $0) ; CWD=$(pwd)
@@ -125,9 +126,9 @@ sed -i -e 's/%''{release}/slack15/g' bfd/Makefile{.am,.in}
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# End of preparations
if echo "$*" | grep -qw -- --prep ; then
@@ -248,7 +249,7 @@ gzip -9 $PKG/usr/info/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp \
- COPYING* ChangeLog.linux MAI* README* \
+ COPYING* ChangeLog* MAI* README* \
$PKG/usr/doc/$PRGNAM-$VERSION
# If there's a ChangeLog, installing at least part of the recent history
@@ -259,8 +260,6 @@ if [ -r ChangeLog ]; then
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
-chown -R root:root $PKG/$PREFIX/doc/binutils-$VERSION
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc