summaryrefslogtreecommitdiffstats
path: root/system/mysql-utilities
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2013-11-11 03:23:11 +0100
committer Robby Workman2013-11-11 17:53:36 +0100
commit0bc874957060a02e98ddc8a1f4d733c0af4b5539 (patch)
treeee820984250fea3d468e9984946dab81e7d0c1cf /system/mysql-utilities
parent547591c01bf8208fec772d9c3d48d43e0ea95b12 (diff)
downloadslackbuilds-0bc874957060a02e98ddc8a1f4d733c0af4b5539.tar.gz
system/mysql-utilities: Added (MySQL Command-Line Utilities)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackware-id.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system/mysql-utilities')
-rw-r--r--system/mysql-utilities/README6
-rw-r--r--system/mysql-utilities/mysql-utilities.SlackBuild90
-rw-r--r--system/mysql-utilities/mysql-utilities.info10
-rw-r--r--system/mysql-utilities/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/system/mysql-utilities/README b/system/mysql-utilities/README
new file mode 100644
index 0000000000..0639a95d27
--- /dev/null
+++ b/system/mysql-utilities/README
@@ -0,0 +1,6 @@
+MySQL Utilities provides a collection of command-line utilities that
+are used for maintaining and administering MySQL servers, including:
+
+Admin Utilities (Clone, Copy, Compare, Diff, Export, Import)
+Replication Utilities (Setup, Configuration)
+General Utilities (Disk Usage, Redundant Indexes, Search Meta Data) \ No newline at end of file
diff --git a/system/mysql-utilities/mysql-utilities.SlackBuild b/system/mysql-utilities/mysql-utilities.SlackBuild
new file mode 100644
index 0000000000..a8f99a866a
--- /dev/null
+++ b/system/mysql-utilities/mysql-utilities.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for mysql-utilities
+
+# Copyright 2013 Willy Sudiarto Raharjo <willysr@slackware-id.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mysql-utilities
+VERSION=${VERSION:-1.3.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.txt README.txt CHANGES.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/mysql-utilities/mysql-utilities.info b/system/mysql-utilities/mysql-utilities.info
new file mode 100644
index 0000000000..4fa1cb0a70
--- /dev/null
+++ b/system/mysql-utilities/mysql-utilities.info
@@ -0,0 +1,10 @@
+PRGNAM="mysql-utilities"
+VERSION="1.3.5"
+HOMEPAGE="https://dev.mysql.com/downloads/tools/utilities/"
+DOWNLOAD="http://cdn.mysql.com/Downloads/MySQLGUITools/mysql-utilities-1.3.5.tar.gz"
+MD5SUM="8629774ab079b32482fe2173445c4b0b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mysql-connector-python"
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackware-id.org"
diff --git a/system/mysql-utilities/slack-desc b/system/mysql-utilities/slack-desc
new file mode 100644
index 0000000000..340b842a68
--- /dev/null
+++ b/system/mysql-utilities/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mysql-utilities: mysql-utilities (MySQL Command-Line Utilities)
+mysql-utilities:
+mysql-utilities: MySQL Utilities provides a collection of command-line utilities that
+mysql-utilities: are used for maintaining and administering MySQL servers, including:
+mysql-utilities:
+mysql-utilities: Admin Utilities (Clone, Copy, Compare, Diff, Export, Import)
+mysql-utilities: Replication Utilities (Setup, Configuration)
+mysql-utilities: General Utilities (Disk Usage, Redundant Indexes, Search Meta Data)
+mysql-utilities:
+mysql-utilities:
+mysql-utilities: