summaryrefslogtreecommitdiffstats
path: root/system/linuxconsoletools/linuxconsoletools.SlackBuild
diff options
context:
space:
mode:
author B. Watson2018-10-30 06:09:33 +0100
committer Willy Sudiarto Raharjo2018-11-03 01:46:56 +0100
commitde86cfbf49af56bc677e99c1a8577f026fd8749f (patch)
tree3db8b909f9470b78b4dbafa4434cf4c9d3a8a1b6 /system/linuxconsoletools/linuxconsoletools.SlackBuild
parent71b4e9690e8133bc2da161d01dc956aa018230f3 (diff)
downloadslackbuilds-de86cfbf49af56bc677e99c1a8577f026fd8749f.tar.gz
system/linuxconsoletools: Document gpm conflict.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/linuxconsoletools/linuxconsoletools.SlackBuild')
-rw-r--r--system/linuxconsoletools/linuxconsoletools.SlackBuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/system/linuxconsoletools/linuxconsoletools.SlackBuild b/system/linuxconsoletools/linuxconsoletools.SlackBuild
index 280fd139b6..129224725c 100644
--- a/system/linuxconsoletools/linuxconsoletools.SlackBuild
+++ b/system/linuxconsoletools/linuxconsoletools.SlackBuild
@@ -22,18 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 20140315 bkw: took over maintenance, updated for 1.4.7, replaced patch
-# with a bit of sed.
-
-# 20150505 bkw: update for v1.4.8
-
-# 20160726 bkw: update for v1.5.1
-
+# 20181030 bkw: add GPM_COMPAT=yes option, minor cleanups, BUILD=2
# 20161015 bkw: update for v1.6.0
+# 20160726 bkw: update for v1.5.1
+# 20150505 bkw: update for v1.4.8
+# 20140315 bkw: took over maintenance, updated for 1.4.7,
+# replaced patch with a bit of sed.
PRGNAM=linuxconsoletools
VERSION=${VERSION:-1.6.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,11 +70,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# install manpages in /usr/man instead of /usr/share/man
sed -i 's,share/man,man,g' docs/Makefile
@@ -86,6 +81,14 @@ make CFLAGS="$SLKCFLAGS" LDFLAGS="-Wl,-s" PREFIX=/usr
make install DESTDIR=$PKG PREFIX=/usr
gzip -9 $PKG/usr/man/man?/*.?
+# keep inputattach from overwriting Slackware's inputattach, if desired.
+# default is to overwrite, because the new inputattach supports many more
+# devices than the old one, and is just a newer version of the same thing.
+if [ "${GPM_COMPAT:-no}" = "yes" ]; then
+ mv $PKG/usr/bin/inputattach $PKG/usr/bin/inputattach-lct
+ mv $PKG/usr/man/man1/inputattach.1.gz $PKG/usr/man/man1/inputattach-lct.1.gz
+fi
+
mkdir -p $PKG/lib/udev/rules.d/
install -m 0644 $CWD/90-joystick.rules $PKG/lib/udev/rules.d/90-joystick.rules