summaryrefslogtreecommitdiffstats
path: root/system/fprintd
diff options
context:
space:
mode:
author Fabio Bas2023-03-11 16:11:26 +0100
committer Willy Sudiarto Raharjo2023-03-11 16:11:26 +0100
commitbfc0613d5ff228301737e5e7021eccb549356f70 (patch)
treec928d2a4bdd83e94c5406526c5c1f99c2105bb9e /system/fprintd
parent6c329d86048e6594d6a4acaea40e1c9d7c1a7bc2 (diff)
downloadslackbuilds-bfc0613d5ff228301737e5e7021eccb549356f70.tar.gz
system/fprintd: Add official patches.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/fprintd')
-rw-r--r--system/fprintd/README12
-rw-r--r--system/fprintd/fprintd.SlackBuild22
2 files changed, 25 insertions, 9 deletions
diff --git a/system/fprintd/README b/system/fprintd/README
index 6e56d00df9..1ea6e16317 100644
--- a/system/fprintd/README
+++ b/system/fprintd/README
@@ -5,5 +5,13 @@ fingerprint authentication to OSes, desktop environments and
applications.
It also includes small command-line utilities if your desktop
environment does not integrate support.
-A PAM module to implement user login (pam_fprintd) is unavailable on
-Slackware since it requires systemd.
+A PAM module to implement user login (pam_fprintd) is available.
+To enable it add these lines on top of /etc/pam.d/sddm:
+
+auth sufficient pam_unix.so try_first_pass likeauth nullok
+auth sufficient pam_fprintd.so
+
+And /etc/pam.d/kde:
+
+auth sufficient pam_unix.so try_first_pass likeauth nullok
+auth sufficient pam_fprintd.so
diff --git a/system/fprintd/fprintd.SlackBuild b/system/fprintd/fprintd.SlackBuild
index 0f895acf79..c880e58f18 100644
--- a/system/fprintd/fprintd.SlackBuild
+++ b/system/fprintd/fprintd.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=fprintd
VERSION=${VERSION:-1.94.2}
SRCVERSION=v${VERSION}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,18 +77,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Disable tests since tehy require various python modules
-sed '154,158 {s/^/#/}' -i meson.build
-sed '204,205 {s/^/#/}' -i meson.build
-sed -e "/subdir('tests')/ s/^#*/#/" -i meson.build
+# Patches
+if [ -d $CWD/patches ]; then
+ for file in $CWD/patches/*.patch ; do
+ if [ -f $file ]; then
+ cat $file | patch -p1 --verbose || exit 1
+ fi
+ done
+fi
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
- meson .. \
+ meson setup .. \
+ -Dman=true \
+ -Dgtk_doc=false \
-Dsystemd=false \
- -Dpam=false \
+ -Dlibsystemd=libelogind \
+ -Dpam=true \
+ -Dpam_modules_dir=/lib${LIBDIRSUFFIX}/security \
--buildtype=release \
--infodir=/usr/info \
--libdir=/usr/lib${LIBDIRSUFFIX} \