summaryrefslogtreecommitdiffstats
path: root/system/fdupes
diff options
context:
space:
mode:
author LukenShiro2013-11-15 15:34:04 +0100
committer Robby Workman2013-11-15 20:45:29 +0100
commitb806c84a7c07ef3e0529511905f8e0ec2831123e (patch)
treed88f9ec8efb6be0020ee0037f3f80dacea4b24ea /system/fdupes
parent6208d04856dff7905e0a1862697d6a2079619775 (diff)
downloadslackbuilds-b806c84a7c07ef3e0529511905f8e0ec2831123e.tar.gz
system/fdupes: Updated for version 1.51.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/fdupes')
-rw-r--r--system/fdupes/fdupes-1.51-destdir.patch29
-rw-r--r--system/fdupes/fdupes.SlackBuild30
-rw-r--r--system/fdupes/fdupes.info6
-rw-r--r--system/fdupes/slack-desc12
4 files changed, 57 insertions, 20 deletions
diff --git a/system/fdupes/fdupes-1.51-destdir.patch b/system/fdupes/fdupes-1.51-destdir.patch
new file mode 100644
index 0000000000..e2fd8b2fe1
--- /dev/null
+++ b/system/fdupes/fdupes-1.51-destdir.patch
@@ -0,0 +1,29 @@
+diff -Naur fdupes-1.51.orig/Makefile fdupes-1.51/Makefile
+--- fdupes-1.51.orig/Makefile 2013-04-20 12:51:58.000000000 -0500
++++ fdupes-1.51/Makefile 2013-07-16 09:22:30.169197997 -0500
+@@ -46,6 +46,8 @@
+ #
+ PROGRAM_NAME=fdupes
+
++DESTDIR =
++
+ #
+ # BIN_DIR indicates directory where program is to be installed.
+ # Suggested value is "$(PREFIX)/bin"
+@@ -103,12 +105,12 @@
+ $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
+
+ installdirs:
+- test -d $(BIN_DIR) || $(MKDIR) $(BIN_DIR)
+- test -d $(MAN_DIR) || $(MKDIR) $(MAN_DIR)
++ test -d $(DESTDIR)$(BIN_DIR) || $(MKDIR) $(DESTDIR)$(BIN_DIR)
++ test -d $(DESTDIR)$(MAN_DIR) || $(MKDIR) $(DESTDIR)$(MAN_DIR)
+
+ install: fdupes installdirs
+- $(INSTALL_PROGRAM) fdupes $(BIN_DIR)/$(PROGRAM_NAME)
+- $(INSTALL_DATA) fdupes.1 $(MAN_DIR)/$(PROGRAM_NAME).$(MAN_EXT)
++ $(INSTALL_PROGRAM) fdupes $(DESTDIR)$(BIN_DIR)/$(PROGRAM_NAME)
++ $(INSTALL_DATA) fdupes.1 $(DESTDIR)$(MAN_DIR)/$(PROGRAM_NAME).$(MAN_EXT)
+
+ clean:
+ $(RM) $(OBJECT_FILES)
diff --git a/system/fdupes/fdupes.SlackBuild b/system/fdupes/fdupes.SlackBuild
index 7730e1c804..8c9835ec4a 100644
--- a/system/fdupes/fdupes.SlackBuild
+++ b/system/fdupes/fdupes.SlackBuild
@@ -1,12 +1,10 @@
#!/bin/bash
# Slackware build script for duplicate file finder fdupes.
-
-# 17/12/2008 - Original script.
-# 28/05/2009 - Updated for Slackware64 and general tidy up.
-# 19/06/2011 - Updated to version 1.50-PR2
# Copyright 2008-2011 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
+# Copyright 2013 LukenShiro, Italy
+
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,9 +23,13 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# 17/12/2008 - Original script.
+# 28/05/2009 - Updated for Slackware64 and general tidy up.
+# 19/06/2011 - Updated to version 1.50-PR2
PRGNAM=fdupes
-VERSION=1.50_PR2
+VERSION=${VERSION:-1.51}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,6 +62,8 @@ else
LIBDIRSUFFIX=""
fi
+DOCFILES="CHANGES CONTRIBUTORS INSTALL README TODO"
+
set -e
rm -rf $PKG
@@ -69,21 +73,25 @@ rm -rf $PRGNAM-$SRCVERS
tar -xvf $CWD/$PRGNAM-$SRCVERS.tar.gz
cd $PRGNAM-$SRCVERS
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix apparent typo in Makefile
-sed -i 's/-$(MKDIR)/$(MKDIR)/g' Makefile
+# apply a patch by hobbes1069<at>gmail<dot>com for DESTDIR (issue #29)
+patch -p1 < $CWD/fdupes-1.51-destdir.patch
-make install PREFIX=$PKG/usr COMPILER_OPTIONS="$SLKCFLAGS"
+make install DESTDIR=$PKG PREFIX=/usr COMPILER_OPTIONS="$SLKCFLAGS"
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES CONTRIBUTORS INSTALL README TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/fdupes/fdupes.info b/system/fdupes/fdupes.info
index 2523e1f26c..1595296dc4 100644
--- a/system/fdupes/fdupes.info
+++ b/system/fdupes/fdupes.info
@@ -1,8 +1,8 @@
PRGNAM="fdupes"
-VERSION="1.50_PR2"
+VERSION="1.51"
HOMEPAGE="http://code.google.com/p/fdupes/"
-DOWNLOAD="http://fdupes.googlecode.com/files/fdupes-1.50-PR2.tar.gz"
-MD5SUM="a4f0de2d9a79efce3d712d6520e58c7f"
+DOWNLOAD="http://fdupes.googlecode.com/files/fdupes-1.51.tar.gz"
+MD5SUM="47d0410c90c9e51e450933ba35a32b62"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/fdupes/slack-desc b/system/fdupes/slack-desc
index 636c5e588c..536d9406a3 100644
--- a/system/fdupes/slack-desc
+++ b/system/fdupes/slack-desc
@@ -1,16 +1,16 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
fdupes: FDUPES (program for identifying or deleting duplicate files)
fdupes:
-fdupes: FDUPES is a program for identifying or deleting duplicate files
+fdupes: FDUPES is a program for identifying or deleting duplicate files
fdupes: residing within specified directories.
-fdupes:
+fdupes:
fdupes: Homepage: http://code.google.com/p/fdupes/
fdupes:
fdupes: