summaryrefslogtreecommitdiffstats
path: root/system/bonnie++/bonnie++.SlackBuild
diff options
context:
space:
mode:
author Vincent Batts2010-05-13 00:39:43 +0200
committer Erik Hanson2010-05-13 00:39:43 +0200
commit8b34488c142c5fefc60e2483fc9503ba0709d8e8 (patch)
treed3469c6a55a49aad98853ae50e82ddaa7cf3c53e /system/bonnie++/bonnie++.SlackBuild
parent68e5fe8f724f8e9f75c1d1efc409ff6b9dba7361 (diff)
downloadslackbuilds-8b34488c142c5fefc60e2483fc9503ba0709d8e8.tar.gz
system/bonnie++: Updated for version 1.03e
Diffstat (limited to 'system/bonnie++/bonnie++.SlackBuild')
-rw-r--r--system/bonnie++/bonnie++.SlackBuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/system/bonnie++/bonnie++.SlackBuild b/system/bonnie++/bonnie++.SlackBuild
index 09f9c3234e..63a849d10b 100644
--- a/system/bonnie++/bonnie++.SlackBuild
+++ b/system/bonnie++/bonnie++.SlackBuild
@@ -5,7 +5,7 @@
# Modified by Michiel van Wessem <michiel@slackbuils.org>
PRGNAM=bonnie++
-VERSION=1.03d
+VERSION=1.03e
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -17,8 +17,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -42,6 +47,7 @@ patch -p1 < $CWD/Makefile.in_DESTDIR.diff
./configure \
--prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
@@ -51,8 +57,10 @@ make MORECFLAGS="$SLKCFLAGS"
make install DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
@@ -68,4 +76,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}