summaryrefslogtreecommitdiffstats
path: root/system/barman/barman.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-09-26 19:31:05 +0200
committer Willy Sudiarto Raharjo2016-10-01 02:28:39 +0200
commitb82bc6432869d4a7f54a582f9d316380b6ffbd36 (patch)
tree53a5bd87441e052a2f7df597570c2ce7c86de23e /system/barman/barman.SlackBuild
parentd7712e4c5d93d96c495c03471ec417cd6f0db5d2 (diff)
downloadslackbuilds-b82bc6432869d4a7f54a582f9d316380b6ffbd36.tar.gz
system/barman: Updated for version 2.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'system/barman/barman.SlackBuild')
-rw-r--r--system/barman/barman.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/system/barman/barman.SlackBuild b/system/barman/barman.SlackBuild
index 4743074e81..e6d12c6ddd 100644
--- a/system/barman/barman.SlackBuild
+++ b/system/barman/barman.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=barman
-VERSION=${VERSION:-1.6.1}
+VERSION=${VERSION:-2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# fix man pages paths
sed -i 's/share\/man/man/g' setup.py