summaryrefslogtreecommitdiffstats
path: root/system/autoarchive
diff options
context:
space:
mode:
author B. Watson2022-04-02 21:50:09 +0200
committer B. Watson2022-04-02 21:50:09 +0200
commitc28711cb40a316b00567a08fd04533d989126e3b (patch)
tree5cf8a76e48cae4dcafabc6c2844a1b619aacae00 /system/autoarchive
parentc75cf4867822a31e411a8cfd5aee260c76dd94af (diff)
downloadslackbuilds-c28711cb40a316b00567a08fd04533d989126e3b.tar.gz
system/autoarchive: Fix broken man page symlink.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/autoarchive')
-rw-r--r--system/autoarchive/autoarchive.SlackBuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/system/autoarchive/autoarchive.SlackBuild b/system/autoarchive/autoarchive.SlackBuild
index 7367777c49..3edec57b0c 100644
--- a/system/autoarchive/autoarchive.SlackBuild
+++ b/system/autoarchive/autoarchive.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220402 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix broken man page symlink.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=autoarchive
VERSION=${VERSION:-2.0.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +75,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# fix docs path
sed -i 's/share\/doc/doc/' setup.py
@@ -91,7 +91,8 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mv $PKG/etc/aa/aa.conf $PKG/etc/aa/aa.conf.new
-find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README COPYING NEWS PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION