summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Leo C2019-12-14 23:25:22 +0100
committer Willy Sudiarto Raharjo2019-12-14 23:25:22 +0100
commite48b2464b46743d3c5eedd3226b69326f18c9d17 (patch)
treeec423268e2acb46b220d561092777c10cec64778 /python
parente6077d43fb0decd570ad2d86777af9e269e19eeb (diff)
downloadslackbuilds-e48b2464b46743d3c5eedd3226b69326f18c9d17.tar.gz
python/python-iso3166: Added (Standalone ISO 3166-1).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-iso3166/README5
-rw-r--r--python/python-iso3166/python-iso3166.SlackBuild91
-rw-r--r--python/python-iso3166/python-iso3166.info10
-rw-r--r--python/python-iso3166/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/python-iso3166/README b/python/python-iso3166/README
new file mode 100644
index 0000000000..3443532c4a
--- /dev/null
+++ b/python/python-iso3166/README
@@ -0,0 +1,5 @@
+ISO 3166-1 defines two-letter, three-letter, and three-digit country
+codes. python-iso3166 is a self-contained module that converts between
+these codes and the corresponding country name.
+
+Python3 is an optional dependency.
diff --git a/python/python-iso3166/python-iso3166.SlackBuild b/python/python-iso3166/python-iso3166.SlackBuild
new file mode 100644
index 0000000000..418a1a900a
--- /dev/null
+++ b/python/python-iso3166/python-iso3166.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for python-iso3166
+
+# Copyright 2019 Leonardo Citrolo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-iso3166
+VERSION=${VERSION:-1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-iso3166/python-iso3166.info b/python/python-iso3166/python-iso3166.info
new file mode 100644
index 0000000000..47170e5065
--- /dev/null
+++ b/python/python-iso3166/python-iso3166.info
@@ -0,0 +1,10 @@
+PRGNAM="python-iso3166"
+VERSION="1.0"
+HOMEPAGE="https://github.com/deactivated/python-iso3166"
+DOWNLOAD="https://github.com/deactivated/python-iso3166/archive/v1.0/python-iso3166-1.0.tar.gz"
+MD5SUM="2aa746b58e393b29ed55896db15860fa"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Leo C."
+EMAIL="leoc@gmx.com"
diff --git a/python/python-iso3166/slack-desc b/python/python-iso3166/slack-desc
new file mode 100644
index 0000000000..60af8677ac
--- /dev/null
+++ b/python/python-iso3166/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-iso3166: python-iso3166 (Standalone ISO 3166-1 country definitions)
+python-iso3166:
+python-iso3166: ISO 3166-1 defines two-letter, three-letter, and three-digit country
+python-iso3166: codes. python-iso3166 is a self-contained module that converts between
+python-iso3166: these codes and the corresponding country name.
+python-iso3166:
+python-iso3166:
+python-iso3166:
+python-iso3166:
+python-iso3166: Homepage: https://github.com/deactivated/python-iso3166
+python-iso3166: