summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Pr. HORSTMANN2020-12-26 08:34:07 +0100
committer Willy Sudiarto Raharjo2020-12-26 08:34:07 +0100
commitc0f3926ebe19d63c985dd539c31355d3ce3faa31 (patch)
tree6319745acf4b82de8ac8e155e71a5fd467c022a9 /python
parent0630699daa3526ccfaaba9394eb3b804a754ab37 (diff)
downloadslackbuilds-c0f3926ebe19d63c985dd539c31355d3ce3faa31.tar.gz
python/python-uritemplate: Added (A python library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-uritemplate/README1
-rw-r--r--python/python-uritemplate/python-uritemplate.SlackBuild95
-rw-r--r--python/python-uritemplate/python-uritemplate.info10
-rw-r--r--python/python-uritemplate/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/python-uritemplate/README b/python/python-uritemplate/README
new file mode 100644
index 0000000000..5e26084706
--- /dev/null
+++ b/python/python-uritemplate/README
@@ -0,0 +1 @@
+Simple python library to deal with URI Templates.
diff --git a/python/python-uritemplate/python-uritemplate.SlackBuild b/python/python-uritemplate/python-uritemplate.SlackBuild
new file mode 100644
index 0000000000..2609e766d3
--- /dev/null
+++ b/python/python-uritemplate/python-uritemplate.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# SlackBuild build script for "python-uritemplate".
+
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-uritemplate
+SRCNAM=uritemplate
+VERSION=${VERSION:-3.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ MOSCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ MOSCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ MOSCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ MOSCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-uritemplate/python-uritemplate.info b/python/python-uritemplate/python-uritemplate.info
new file mode 100644
index 0000000000..e3273f872a
--- /dev/null
+++ b/python/python-uritemplate/python-uritemplate.info
@@ -0,0 +1,10 @@
+PRGNAM="python-uritemplate"
+VERSION="3.0.1"
+HOMEPAGE="https://github.com/uri-templates/"
+DOWNLOAD="https://files.pythonhosted.org/packages/42/da/fa9aca2d866f932f17703b3b5edb7b17114bb261122b6e535ef0d9f618f8/uritemplate-3.0.1.tar.gz"
+MD5SUM="869fb44fbd56713490db7272eb36c8ae"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/python-uritemplate/slack-desc b/python/python-uritemplate/slack-desc
new file mode 100644
index 0000000000..da1c10ebd9
--- /dev/null
+++ b/python/python-uritemplate/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-uritemplate: python-uritemplate (A python library)
+python-uritemplate:
+python-uritemplate: Simple python library to deal with URI Templates.
+python-uritemplate:
+python-uritemplate:
+python-uritemplate:
+python-uritemplate: Homepage: https://github.com/uri-templates/
+python-uritemplate:
+python-uritemplate:
+python-uritemplate:
+python-uritemplate: