summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Pr. HORSTMANN2020-12-11 19:41:32 +0100
committer Willy Sudiarto Raharjo2020-12-12 01:09:20 +0100
commit9b0201a97550540032a8e3bcc695f51e2cb6ae09 (patch)
tree928681eb4e4d07dd13ca57938e037827abea5a09 /python
parent052e5b9e57497ebe42fa62d8c6894d0e8520e682 (diff)
downloadslackbuilds-9b0201a97550540032a8e3bcc695f51e2cb6ae09.tar.gz
python/click-repl: Added (REPL plugin for Click)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/click-repl/README6
-rw-r--r--python/click-repl/click-repl.SlackBuild81
-rw-r--r--python/click-repl/click-repl.info10
-rw-r--r--python/click-repl/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/click-repl/README b/python/click-repl/README
new file mode 100644
index 0000000000..89e6ffaa86
--- /dev/null
+++ b/python/click-repl/README
@@ -0,0 +1,6 @@
+REPL plugin for Click
+For Python2 and Python3.
+
+OPTIONAL:
+
+python3
diff --git a/python/click-repl/click-repl.SlackBuild b/python/click-repl/click-repl.SlackBuild
new file mode 100644
index 0000000000..0e911cdb10
--- /dev/null
+++ b/python/click-repl/click-repl.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# SlackBuild build script for click-repl
+
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=click-repl
+SRCPKG=${SRCPKG-click-repl}
+VERSION=${VERSION:-0.1.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $SRCPKG | cut -d- -f1-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+ makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
diff --git a/python/click-repl/click-repl.info b/python/click-repl/click-repl.info
new file mode 100644
index 0000000000..f04702a1fa
--- /dev/null
+++ b/python/click-repl/click-repl.info
@@ -0,0 +1,10 @@
+PRGNAM="click-repl"
+VERSION="0.1.6"
+HOMEPAGE="https://pypi.org/project/click-repl/"
+DOWNLOAD="https://files.pythonhosted.org/packages/51/99/6a722e232f92fdc21c46fd042fea63e7c2fcda3086ff5db62edd595d3f49/click-repl-0.1.6.tar.gz"
+MD5SUM="2d5f4d42cbd1da9a50a49dff4d6087ca"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/click-repl/slack-desc b/python/click-repl/slack-desc
new file mode 100644
index 0000000000..512820ba1f
--- /dev/null
+++ b/python/click-repl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |----------------------------------------------------------------------|
+click-repl: click-repl (REPL plugin for Click)
+click-repl:
+click-repl:
+click-repl:
+click-repl:
+click-repl:
+click-repl: Homepage: https://pypi.org/project/click-repl/
+click-repl:
+click-repl:
+click-repl:
+click-repl: