summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Audrius Kažukauskas2014-05-29 01:24:38 +0200
committer Willy Sudiarto Raharjo2014-05-29 01:24:38 +0200
commit99ccbd65b57bb09b1feff1a611655163377144da (patch)
treedc630092e4173052f1409ae4c23b53be8b8fc925 /python
parent81efe6c63650341e1604ba158268b131e9801755 (diff)
downloadslackbuilds-99ccbd65b57bb09b1feff1a611655163377144da.tar.gz
python/python3: Updated for version 3.4.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3/README4
-rw-r--r--python/python3/patches/python3.x86_64.diff62
-rw-r--r--python/python3/python3.SlackBuild12
-rw-r--r--python/python3/python3.info8
4 files changed, 39 insertions, 47 deletions
diff --git a/python/python3/README b/python/python3/README
index e5171230e3..ddb5c9bcb1 100644
--- a/python/python3/README
+++ b/python/python3/README
@@ -13,3 +13,7 @@ standard library has been reorganized in a few prominent places.
It is safe to install this on a system which already has 2.x version of
Python.
+
+If you'd like to have HTML docs installed, get them from
+<https://docs.python.org/3/download.html> (HTML format, .tar.bz2
+archive).
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 8fced1404b..1c4aa6e0ef 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.4.0.orig/Lib/distutils/command/install.py Python-3.4.0/Lib/distutils/command/install.py
---- Python-3.4.0.orig/Lib/distutils/command/install.py 2014-03-17 04:31:29.000000000 +0200
-+++ Python-3.4.0/Lib/distutils/command/install.py 2014-03-29 12:41:46.360404163 +0200
+diff -uar Python-3.4.1.orig/Lib/distutils/command/install.py Python-3.4.1/Lib/distutils/command/install.py
+--- Python-3.4.1.orig/Lib/distutils/command/install.py 2014-05-19 08:19:37.000000000 +0300
++++ Python-3.4.1/Lib/distutils/command/install.py 2014-05-25 16:53:03.729600470 +0300
@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
@@ -21,9 +21,9 @@ diff -uar Python-3.4.0.orig/Lib/distutils/command/install.py Python-3.4.0/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.4.0.orig/Lib/distutils/sysconfig.py Python-3.4.0/Lib/distutils/sysconfig.py
---- Python-3.4.0.orig/Lib/distutils/sysconfig.py 2014-03-17 04:31:29.000000000 +0200
-+++ Python-3.4.0/Lib/distutils/sysconfig.py 2014-03-29 12:41:46.360404163 +0200
+diff -uar Python-3.4.1.orig/Lib/distutils/sysconfig.py Python-3.4.1/Lib/distutils/sysconfig.py
+--- Python-3.4.1.orig/Lib/distutils/sysconfig.py 2014-05-19 08:19:38.000000000 +0300
++++ Python-3.4.1/Lib/distutils/sysconfig.py 2014-05-25 16:53:03.729600470 +0300
@@ -142,7 +142,7 @@
if os.name == "posix":
@@ -33,9 +33,9 @@ diff -uar Python-3.4.0.orig/Lib/distutils/sysconfig.py Python-3.4.0/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.4.0.orig/Lib/site.py Python-3.4.0/Lib/site.py
---- Python-3.4.0.orig/Lib/site.py 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Lib/site.py 2014-03-29 12:45:39.339784221 +0200
+diff -uar Python-3.4.1.orig/Lib/site.py Python-3.4.1/Lib/site.py
+--- Python-3.4.1.orig/Lib/site.py 2014-05-19 08:19:38.000000000 +0300
++++ Python-3.4.1/Lib/site.py 2014-05-25 16:53:03.729600470 +0300
@@ -304,13 +304,13 @@
seen.add(prefix)
@@ -52,9 +52,9 @@ diff -uar Python-3.4.0.orig/Lib/site.py Python-3.4.0/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.4.0.orig/Lib/sysconfig.py Python-3.4.0/Lib/sysconfig.py
---- Python-3.4.0.orig/Lib/sysconfig.py 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Lib/sysconfig.py 2014-03-29 12:41:46.361404197 +0200
+diff -uar Python-3.4.1.orig/Lib/sysconfig.py Python-3.4.1/Lib/sysconfig.py
+--- Python-3.4.1.orig/Lib/sysconfig.py 2014-05-19 08:19:38.000000000 +0300
++++ Python-3.4.1/Lib/sysconfig.py 2014-05-25 16:53:03.729600470 +0300
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -100,21 +100,9 @@ diff -uar Python-3.4.0.orig/Lib/sysconfig.py Python-3.4.0/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.4.0.orig/Lib/venv/__init__.py Python-3.4.0/Lib/venv/__init__.py
---- Python-3.4.0.orig/Lib/venv/__init__.py 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Lib/venv/__init__.py 2014-03-29 12:41:46.361404197 +0200
-@@ -133,7 +133,7 @@
- else:
- binname = 'bin'
- incpath = 'include'
-- libpath = os.path.join(env_dir, 'lib', 'python%d.%d' % sys.version_info[:2], 'site-packages')
-+ libpath = os.path.join(env_dir, 'lib64', 'python%d.%d' % sys.version_info[:2], 'site-packages')
- context.inc_path = path = os.path.join(env_dir, incpath)
- create_if_needed(path)
- create_if_needed(libpath)
-diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
---- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:41:46.361404197 +0200
+diff -uar Python-3.4.1.orig/Makefile.pre.in Python-3.4.1/Makefile.pre.in
+--- Python-3.4.1.orig/Makefile.pre.in 2014-05-19 08:19:39.000000000 +0300
++++ Python-3.4.1/Makefile.pre.in 2014-05-25 16:53:03.729600470 +0300
@@ -115,7 +115,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -124,9 +112,9 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.4.0.orig/Modules/getpath.c Python-3.4.0/Modules/getpath.c
---- Python-3.4.0.orig/Modules/getpath.c 2014-03-17 04:31:31.000000000 +0200
-+++ Python-3.4.0/Modules/getpath.c 2014-03-29 12:58:32.943849510 +0200
+diff -uar Python-3.4.1.orig/Modules/getpath.c Python-3.4.1/Modules/getpath.c
+--- Python-3.4.1.orig/Modules/getpath.c 2014-05-19 08:19:39.000000000 +0300
++++ Python-3.4.1/Modules/getpath.c 2014-05-25 16:53:03.730600494 +0300
@@ -118,8 +118,8 @@
#endif
@@ -165,10 +153,10 @@ diff -uar Python-3.4.0.orig/Modules/getpath.c Python-3.4.0/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.4.0.orig/configure Python-3.4.0/configure
---- Python-3.4.0.orig/configure 2014-03-17 04:31:31.000000000 +0200
-+++ Python-3.4.0/configure 2014-03-29 14:11:12.338969032 +0200
-@@ -13953,7 +13953,7 @@
+diff -uar Python-3.4.1.orig/configure Python-3.4.1/configure
+--- Python-3.4.1.orig/configure 2014-05-19 08:19:40.000000000 +0300
++++ Python-3.4.1/configure 2014-05-25 16:53:03.731600519 +0300
+@@ -13930,7 +13930,7 @@
$as_echo "$LDVERSION" >&6; }
@@ -177,9 +165,9 @@ diff -uar Python-3.4.0.orig/configure Python-3.4.0/configure
# Check whether right shifting a negative integer extends the sign bit
-diff -uar Python-3.4.0.orig/setup.py Python-3.4.0/setup.py
---- Python-3.4.0.orig/setup.py 2014-03-17 04:31:31.000000000 +0200
-+++ Python-3.4.0/setup.py 2014-03-29 12:41:46.362404227 +0200
+diff -uar Python-3.4.1.orig/setup.py Python-3.4.1/setup.py
+--- Python-3.4.1.orig/setup.py 2014-05-19 08:19:40.000000000 +0300
++++ Python-3.4.1/setup.py 2014-05-25 16:53:03.732600546 +0300
@@ -445,7 +445,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index 536568c23d..02c865df24 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3
-VERSION=${VERSION:-3.4.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.4.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -120,9 +120,11 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README LICENSE Misc $PKG/usr/doc/$PRGNAM-$VERSION
mv $SITEPK/README $PKG/usr/doc/$PRGNAM-$VERSION/README.python-tools
( cd $PKG/usr/doc/$PRGNAM-$VERSION ; ln -sf $TOOLSDIR Tools )
-tar xf $CWD/python-$VERSION-docs-html.tar.bz2
-mv python-$VERSION-docs-html $PKG/usr/doc/$PRGNAM-$VERSION/html
-chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
+if [ -e "$CWD/python-$VERSION-docs-html.tar.bz2" ]; then
+ tar xf $CWD/python-$VERSION-docs-html.tar.bz2
+ mv python-$VERSION-docs-html $PKG/usr/doc/$PRGNAM-$VERSION/html
+ chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/html
+fi
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3/python3.info b/python/python3/python3.info
index 7bcb0da0bd..d581df6a2f 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,10 +1,8 @@
PRGNAM="python3"
-VERSION="3.4.0"
+VERSION="3.4.1"
HOMEPAGE="http://python.org/"
-DOWNLOAD="https://python.org/ftp/python/3.4.0/Python-3.4.0.tar.xz \
- https://python.org/ftp/python/doc/3.4.0/python-3.4.0-docs-html.tar.bz2"
-MD5SUM="77c22725e14af3d71022cbfdebff4903 \
- cdbef126ee7ef0908352fabc4dc5bee5"
+DOWNLOAD="https://python.org/ftp/python/3.4.1/Python-3.4.1.tar.xz"
+MD5SUM="6cafc183b4106476dd73d5738d7f616a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""