summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-15 02:56:42 +0100
committer Erik Hanson2014-01-30 06:21:02 +0100
commit898944c03d269fc614454f3efdf4f50a5506fc3a (patch)
tree5bb0429ee3ef75ff421e86e4ab21586cdec57597 /python
parentebd8c687db448eb5667ec8b42585bc52ba62f1cf (diff)
downloadslackbuilds-898944c03d269fc614454f3efdf4f50a5506fc3a.tar.gz
python/itsdangerous: Added (Various helpers to pass trusted data).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/itsdangerous/README5
-rw-r--r--python/itsdangerous/itsdangerous.SlackBuild85
-rw-r--r--python/itsdangerous/itsdangerous.info10
-rw-r--r--python/itsdangerous/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/itsdangerous/README b/python/itsdangerous/README
new file mode 100644
index 0000000000..855a564444
--- /dev/null
+++ b/python/itsdangerous/README
@@ -0,0 +1,5 @@
+Various helpers to pass data to untrusted environments and to get it
+back safe and sound.
+This repository provides a module that is a port of the django signing
+module. It's not directly copied but some changes were applied to make
+it work better on its own.
diff --git a/python/itsdangerous/itsdangerous.SlackBuild b/python/itsdangerous/itsdangerous.SlackBuild
new file mode 100644
index 0000000000..1f993b84a1
--- /dev/null
+++ b/python/itsdangerous/itsdangerous.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for itsdangerous
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=itsdangerous
+VERSION=${VERSION:-0.23}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README CHANGES LICENSE PKG-INFO docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/itsdangerous/itsdangerous.info b/python/itsdangerous/itsdangerous.info
new file mode 100644
index 0000000000..d47117df6a
--- /dev/null
+++ b/python/itsdangerous/itsdangerous.info
@@ -0,0 +1,10 @@
+PRGNAM="itsdangerous"
+VERSION="0.23"
+HOMEPAGE="http://github.com/mitsuhiko/itsdangerous"
+DOWNLOAD="https://pypi.python.org/packages/source/i/itsdangerous/itsdangerous-0.23.tar.gz"
+MD5SUM="985e726eb76f18aca81e703f0a6c6efc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/itsdangerous/slack-desc b/python/itsdangerous/slack-desc
new file mode 100644
index 0000000000..0dc77907a3
--- /dev/null
+++ b/python/itsdangerous/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+itsdangerous: itsdangerous (Various helpers to pass trusted data)
+itsdangerous:
+itsdangerous: It's Dangerous ... so better sign this
+itsdangerous: Various helpers to pass data to untrusted environments and to get it
+itsdangerous: back safe and sound.
+itsdangerous: This repository provides a module that is a port of the django signing
+itsdangerous: module. It's not directly copied but some changes were applied to make
+itsdangerous: it work better on its own.
+itsdangerous:
+itsdangerous:
+itsdangerous: Homepage: https://github.com/mitsuhiko/itsdangerous