summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Pr. HORSTMANN2020-12-11 20:15:48 +0100
committer Willy Sudiarto Raharjo2020-12-12 01:09:21 +0100
commit6a064b7c7f2db53a4ccc3470d0b16114d7893209 (patch)
tree37d3f8453406cbfd70caa38103e178ac46d845aa /python
parent0d291fc99775875751c868450a9efce734a4d893 (diff)
downloadslackbuilds-6a064b7c7f2db53a4ccc3470d0b16114d7893209.tar.gz
python/reedsolo: Added (Pure-Python Reed Solomon encoder/decoder)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/reedsolo/README6
-rw-r--r--python/reedsolo/reedsolo.SlackBuild78
-rw-r--r--python/reedsolo/reedsolo.info10
-rw-r--r--python/reedsolo/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/python/reedsolo/README b/python/reedsolo/README
new file mode 100644
index 0000000000..9d20c18954
--- /dev/null
+++ b/python/reedsolo/README
@@ -0,0 +1,6 @@
+Pure-Python Reed Solomon encoder/decoder
+For Python2 and Python3.
+
+OPTIONAL:
+
+python3
diff --git a/python/reedsolo/reedsolo.SlackBuild b/python/reedsolo/reedsolo.SlackBuild
new file mode 100644
index 0000000000..2c7d5dbba2
--- /dev/null
+++ b/python/reedsolo/reedsolo.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# SlackBuild build script for reedsolo
+
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=reedsolo
+VERSION=${VERSION:-1.5.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
diff --git a/python/reedsolo/reedsolo.info b/python/reedsolo/reedsolo.info
new file mode 100644
index 0000000000..481b79f551
--- /dev/null
+++ b/python/reedsolo/reedsolo.info
@@ -0,0 +1,10 @@
+PRGNAM="reedsolo"
+VERSION="1.5.4"
+HOMEPAGE="https://pypi.org/project/reedsolo/"
+DOWNLOAD="https://files.pythonhosted.org/packages/c8/cb/bb2ddbd00c9b4215dd57a2abf7042b0ae222b44522c5eb664a8fd9d786da/reedsolo-1.5.4.tar.gz"
+MD5SUM="89bb392d10ddc5e3d876a7a9e05d103c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/reedsolo/slack-desc b/python/reedsolo/slack-desc
new file mode 100644
index 0000000000..9651aafb8c
--- /dev/null
+++ b/python/reedsolo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+reedsolo: reedsolo (Pure-Python Reed Solomon encoder/decoder)
+reedsolo:
+reedsolo: A pure-python universal errors-and-erasures Reed-Solomon Codec ,
+reedsolo: based on the wonderful tutorial at wikiversity, written by “Bobmath”
+reedsolo: and “LRQ3000”.
+reedsolo:
+reedsolo: Homepage: https://pypi.org/project/reedsolo/
+reedsolo:
+reedsolo:
+reedsolo:
+reedsolo: