summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Mohamed LYAHYAOUI2013-12-25 02:37:17 +0100
committer Robby Workman2013-12-25 22:05:41 +0100
commit56811148231bf789dcb718bf0391d04ea7015ee1 (patch)
tree659232d85b29d3aad4ff34ae94940309a66c5694 /python
parent15aeee6437f54ed7a9fc2b9704c450db049b1928 (diff)
downloadslackbuilds-56811148231bf789dcb718bf0391d04ea7015ee1.tar.gz
python/werkzeug: Added (WSGI utility library for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/werkzeug/README15
-rw-r--r--python/werkzeug/slack-desc21
-rw-r--r--python/werkzeug/werkzeug.SlackBuild88
-rw-r--r--python/werkzeug/werkzeug.info10
4 files changed, 134 insertions, 0 deletions
diff --git a/python/werkzeug/README b/python/werkzeug/README
new file mode 100644
index 0000000000..c1253beb12
--- /dev/null
+++ b/python/werkzeug/README
@@ -0,0 +1,15 @@
+The Swiss Army knife of Python web development
+
+Werkzeug started as simple collection of various utilities for WSGI
+applications and has become one of the most advanced WSGI utility modules.
+It includes a powerful debugger, full featured request and response objects,
+HTTP utilities to handle entity tags, cache control headers, HTTP dates,
+cookie handling, file uploads, a powerful URL routing system and a bunch
+of community contributed addon modules.
+
+Werkzeug is unicode aware and doesn't enforce a specific template engine,
+database adapter or anything else. It doesn't even enforce a specific way
+of handling requests and leaves all that up to the developer.
+
+It's most useful for end user applications which should work on as many
+server environments as possible (such as blogs, wikis, bulletin boards, etc)
diff --git a/python/werkzeug/slack-desc b/python/werkzeug/slack-desc
new file mode 100644
index 0000000000..db7df6eca2
--- /dev/null
+++ b/python/werkzeug/slack-desc
@@ -0,0 +1,21 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+werkzeug: werkzeug (WSGI utility library for Python)
+werkzeug:
+werkzeug: Werkzeug started as simple collection of various utilities for WSGI
+werkzeug: and has become one of the most advanced WSGI utility modules.
+werkzeug: It includes a powerful debugger, fully featured request and response
+werkzeug: objects, HTTP utilities to handle entity tags, cache control headers
+werkzeug: HTTP dates, cookie handling, file uploads, a powerful URL routing
+werkzeug: system and a bunch of community contributed addon modules.
+werkzeug:
+werkzeug: Homepage: http://werkzeug.pocoo.org
+werkzeug:
+
+
diff --git a/python/werkzeug/werkzeug.SlackBuild b/python/werkzeug/werkzeug.SlackBuild
new file mode 100644
index 0000000000..e2e1d8d7c1
--- /dev/null
+++ b/python/werkzeug/werkzeug.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for werkzeug
+
+# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=werkzeug
+SRCNAM=Werkzeug
+VERSION=${VERSION:-0.9.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE PKG-INFO"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py build || exit 1
+
+python setup.py install --root $PKG || exit 1
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/werkzeug/werkzeug.info b/python/werkzeug/werkzeug.info
new file mode 100644
index 0000000000..69aa74a1fa
--- /dev/null
+++ b/python/werkzeug/werkzeug.info
@@ -0,0 +1,10 @@
+PRGNAM="werkzeug"
+VERSION="0.9.4"
+HOMEPAGE="http://werkzeug.pocoo.org"
+DOWNLOAD="https://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-0.9.4.tar.gz"
+MD5SUM="670fad41f57c13b71a6816765765a3dd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Mohamed LYAHYAOUI"
+EMAIL="mlyahyaoui@gmail.com"