summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Tim Dickson2020-01-11 14:29:17 +0100
committer Willy Sudiarto Raharjo2020-01-11 14:58:11 +0100
commit33918d5f91895016208783211fd3c8018e7185e8 (patch)
tree7b1d277fa9a7a6cf86a571bb08517b76d9f3c1c9 /python
parent056abb3963efab4ef4202f8a987a520b72dcc3fd (diff)
downloadslackbuilds-33918d5f91895016208783211fd3c8018e7185e8.tar.gz
python/esptool: Added (Utility to work with ESP8266 and ESP32).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/esptool/README11
-rw-r--r--python/esptool/esptool.SlackBuild89
-rw-r--r--python/esptool/esptool.info10
-rw-r--r--python/esptool/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/python/esptool/README b/python/esptool/README
new file mode 100644
index 0000000000..dc213ef57f
--- /dev/null
+++ b/python/esptool/README
@@ -0,0 +1,11 @@
+A Python-based, open source, platform independent, utility to communicate
+with the ROM bootloader in Espressif ESP8266 & ESP32 chips.
+
+esptool.py was started by Fredrik Ahlberg (@themadinventor) as an
+unofficial community project. It is now also supported by Espressif.
+Current primary maintainer is Angus Gratton (@projectgus).
+
+esptool.py is Free Software under a GPLv2 license.
+
+This (source) is downloaded from pypi.org/projects/esptool as the github
+site does not have a complete sourcecode zip.
diff --git a/python/esptool/esptool.SlackBuild b/python/esptool/esptool.SlackBuild
new file mode 100644
index 0000000000..bbef07de5a
--- /dev/null
+++ b/python/esptool/esptool.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for esptool
+
+# Written by Tim Dickson dickson.tim@googlemail.com
+# Copyright (c) 2020 Tim Dickson, Scotland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# note to self. github source tar.gz misses out typeshed directory contents,
+# so use pypi.org/project/mypy download source tar.gz instead.
+
+PRGNAM=esptool
+VERSION=${VERSION:-2.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md CONTRIBUTING.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/esptool/esptool.info b/python/esptool/esptool.info
new file mode 100644
index 0000000000..0a60442c31
--- /dev/null
+++ b/python/esptool/esptool.info
@@ -0,0 +1,10 @@
+PRGNAM="esptool"
+VERSION="2.8"
+HOMEPAGE="https://github.com/espressif/esptool"
+DOWNLOAD="https://files.pythonhosted.org/packages/68/91/08c182f66fa3f12a96e754ae8ec7762abb2d778429834638f5746f81977a/esptool-2.8.tar.gz"
+MD5SUM="d17b9293910773045b9de0d5caa0597d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyserial"
+MAINTAINER="Tim Dickson"
+EMAIL="dickson.tim@googlemail.com"
diff --git a/python/esptool/slack-desc b/python/esptool/slack-desc
new file mode 100644
index 0000000000..9230464edd
--- /dev/null
+++ b/python/esptool/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+esptool: esptool (Python utility to communicate with ESP8266 and ESP32 chips)
+esptool:
+esptool: esptool is a python based platform independent utility to
+esptool: comminicate with the ROM bootloader in Expressif ESP8266 and ESP32
+esptool: chips.
+esptool:
+esptool: Homepage: https://github.com/espressif/esptool
+esptool:
+esptool:
+esptool:
+esptool: