summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-15 06:21:53 +0100
committer Erik Hanson2014-01-30 06:21:03 +0100
commit0e3f2cd45e94d795e9c3fbe5818a436b06493ffe (patch)
tree9585013203ea72c018469e423d6716f90aa3755d /python
parentc98080fb5d3738ec7d4a322c5405f3224ac595f1 (diff)
downloadslackbuilds-0e3f2cd45e94d795e9c3fbe5818a436b06493ffe.tar.gz
python/waitress: Added (Waitress WSGI server).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/waitress/README5
-rw-r--r--python/waitress/slack-desc19
-rw-r--r--python/waitress/waitress.SlackBuild87
-rw-r--r--python/waitress/waitress.info10
4 files changed, 121 insertions, 0 deletions
diff --git a/python/waitress/README b/python/waitress/README
new file mode 100644
index 0000000000..a1295ae6cb
--- /dev/null
+++ b/python/waitress/README
@@ -0,0 +1,5 @@
+Waitress is meant to be a production-quality pure-Python WSGI server with very
+acceptable performance. It has no dependencies except ones which live in the
+Python standard library. It runs on CPython on Unix and Windows under Python
+2.6+ and Python 3.2+. It is also known to run on PyPy 1.6.0+ on UNIX. It
+supports HTTP/1.0 and HTTP/1.1.
diff --git a/python/waitress/slack-desc b/python/waitress/slack-desc
new file mode 100644
index 0000000000..e4a43c5f68
--- /dev/null
+++ b/python/waitress/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+waitress: waitress (Waitress WSGI server)
+waitress:
+waitress: Waitress is meant to be a production-quality pure-Python
+waitress: WSGI server with very acceptable performance. It has no
+waitress: dependencies except ones which live in the Python standard library.
+waitress: It runs on CPython on Unix and Windows under Python 2.6+ and Python
+waitress: 3.2+. It is also known to run on PyPy 1.6.0+ on UNIX. It supports
+waitress: HTTP/1.0 and HTTP/1.1.
+waitress:
+waitress: Homepage: https://github.com/Pylons/waitress
+waitress:
diff --git a/python/waitress/waitress.SlackBuild b/python/waitress/waitress.SlackBuild
new file mode 100644
index 0000000000..efb75b7f05
--- /dev/null
+++ b/python/waitress/waitress.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for waitress
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=waitress
+VERSION=${VERSION:-0.8.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst CHANGES.txt CONTRIBUTORS.txt COPYRIGHT.txt\
+ LICENSE.txt PKG-INFO TODO.txt tox.ini docs/*.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/waitress/waitress.info b/python/waitress/waitress.info
new file mode 100644
index 0000000000..9482c62ea8
--- /dev/null
+++ b/python/waitress/waitress.info
@@ -0,0 +1,10 @@
+PRGNAM="waitress"
+VERSION="0.8.8"
+HOMEPAGE="https://github.com/Pylons/waitress"
+DOWNLOAD="https://pypi.python.org/packages/source/w/waitress/waitress-0.8.8.tar.gz"
+MD5SUM="c0a40f34b5410348579556cd4a21c1c2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools Sphinx docutils nose coverage"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"