summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Tonus2023-03-06 01:13:19 +0100
committer Willy Sudiarto Raharjo2023-03-12 02:48:31 +0100
commit0e1eb03aa54e24c47505d30f147867a9ead55133 (patch)
tree652bf13eeeca317dbd0c7558371634c5eda13a30 /python
parent281817f077be6e512016a2ae9b38dfb90f7880a0 (diff)
downloadslackbuilds-0e1eb03aa54e24c47505d30f147867a9ead55133.tar.gz
python/hijri-converter: Added (convert Hijr <-> Greogorian date)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/hijri-converter/README15
-rw-r--r--python/hijri-converter/hijri-converter.SlackBuild95
-rw-r--r--python/hijri-converter/hijri-converter.info10
-rw-r--r--python/hijri-converter/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/python/hijri-converter/README b/python/hijri-converter/README
new file mode 100644
index 0000000000..ad341020f2
--- /dev/null
+++ b/python/hijri-converter/README
@@ -0,0 +1,15 @@
+A Python package to convert accurately between Hijri and Gregorian
+dates using the Umm al-Qura calendar.
+Features :
+Accurate and verified date conversion.
+Optimized code performance compared to similar packages.
+Intuitive, clean, and easy-to-use interface.
+Most of the methods and formats are similar to those of standard
+library.
+Multilingual representation of weekday names, months, and calendar
+era notations.
+Easily extendable to support other natural languages.
+Rich comparison between dates.
+Validation of input dates.
+Works on Python 3.6+ with zero dependencies.
+Thoroughly tested with 100% test coverage
diff --git a/python/hijri-converter/hijri-converter.SlackBuild b/python/hijri-converter/hijri-converter.SlackBuild
new file mode 100644
index 0000000000..ac05f13d34
--- /dev/null
+++ b/python/hijri-converter/hijri-converter.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/bash
+
+# Slackware build script for hijri-converter
+
+# Copyright 2023 Tonus Paris
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=hijri-converter
+VERSION=${VERSION:-2.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/hijri-converter/hijri-converter.info b/python/hijri-converter/hijri-converter.info
new file mode 100644
index 0000000000..09aad13d77
--- /dev/null
+++ b/python/hijri-converter/hijri-converter.info
@@ -0,0 +1,10 @@
+PRGNAM="hijri-converter"
+VERSION="2.2.4"
+HOMEPAGE="https://github.com/mhalshehri/hijri-converter"
+DOWNLOAD="https://files.pythonhosted.org/packages/54/6f/96f9880389a20057ce3fdfed70a9cea5eb47d679178a43c55f58a35d98be/hijri-converter-2.2.4.tar.gz"
+MD5SUM="e7bc387a46f72ad2fc4e46daabf47dea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Tonus"
+EMAIL="tonus1@free.fr"
diff --git a/python/hijri-converter/slack-desc b/python/hijri-converter/slack-desc
new file mode 100644
index 0000000000..388bbbc17f
--- /dev/null
+++ b/python/hijri-converter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hijri-converter: hijri-converter (convert between Hijr and Greogorian date)
+hijri-converter:
+hijri-converter: A Python package to convert accurately between Hijri and Gregorian
+hijri-converter: dates using the Umm al-Qura calendar.
+hijri-converter:
+hijri-converter:
+hijri-converter:
+hijri-converter:
+hijri-converter:
+hijri-converter:
+hijri-converter: