summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo2023-09-04 13:47:35 +0200
committer Willy Sudiarto Raharjo2023-09-09 05:14:18 +0200
commitf5552ca696fb653078fedef7a7dfe8a58bd0c18a (patch)
treecbec99415ae878d26c693c9dff506649020cb084 /python
parent257582030fa13ada9fe974a9fda113756744df53 (diff)
downloadslackbuilds-f5552ca696fb653078fedef7a7dfe8a58bd0c18a.tar.gz
python/python3-portend: Updated for version 3.2.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-portend/python3-portend.SlackBuild19
-rw-r--r--python/python3-portend/python3-portend.info6
2 files changed, 13 insertions, 12 deletions
diff --git a/python/python3-portend/python3-portend.SlackBuild b/python/python3-portend/python3-portend.SlackBuild
index 4e0a7b66f3..7ffb4ea805 100644
--- a/python/python3-portend/python3-portend.SlackBuild
+++ b/python/python3-portend/python3-portend.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-portend
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-portend
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-3.1.0}
+VERSION=${VERSION:-3.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,6 +57,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -76,17 +76,18 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst NEWS.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-portend/python3-portend.info b/python/python3-portend/python3-portend.info
index 53b23e7216..7a8323a16b 100644
--- a/python/python3-portend/python3-portend.info
+++ b/python/python3-portend/python3-portend.info
@@ -1,8 +1,8 @@
PRGNAM="python3-portend"
-VERSION="3.1.0"
+VERSION="3.2.0"
HOMEPAGE="https://github.com/jaraco/portend"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/portend/portend-3.1.0.tar.gz"
-MD5SUM="c37d676837505a6fc8dd33185c6d62a7"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/portend/portend-3.2.0.tar.gz"
+MD5SUM="0c3a2e8073c384b826f87795766f1e0e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-tempora"