summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Prof. HORSTMANN2020-06-16 05:56:18 +0200
committer Willy Sudiarto Raharjo2020-06-20 02:59:27 +0200
commitde597a44226d8545b2ea983bc73d3c0f0eba33f3 (patch)
tree1f25b1c66f02adec47968f1eaca74b2c6e7c9f2d /python
parent9fc724612e1769f0eabab0bed1b078c6aa0d7584 (diff)
downloadslackbuilds-de597a44226d8545b2ea983bc73d3c0f0eba33f3.tar.gz
python/pathtools3: Added (File system general utilities)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pathtools3/README3
-rw-r--r--python/pathtools3/pathtools3.SlackBuild80
-rw-r--r--python/pathtools3/pathtools3.info10
-rw-r--r--python/pathtools3/slack-desc19
4 files changed, 112 insertions, 0 deletions
diff --git a/python/pathtools3/README b/python/pathtools3/README
new file mode 100644
index 0000000000..acd0ffffec
--- /dev/null
+++ b/python/pathtools3/README
@@ -0,0 +1,3 @@
+Pattern matching and various utilities for file systems paths.
+
+Optional dependency: python3
diff --git a/python/pathtools3/pathtools3.SlackBuild b/python/pathtools3/pathtools3.SlackBuild
new file mode 100644
index 0000000000..62e863fcea
--- /dev/null
+++ b/python/pathtools3/pathtools3.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# SlackBuild build script for pathtools3
+
+# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=${PRGNAM:-pathtools3}
+SRCPKG=${SRCPKG-pathtools3}
+VERSION=${VERSION:-0.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $SRCPKG | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ # Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pathtools3/pathtools3.info b/python/pathtools3/pathtools3.info
new file mode 100644
index 0000000000..d266c7db9f
--- /dev/null
+++ b/python/pathtools3/pathtools3.info
@@ -0,0 +1,10 @@
+PRGNAM="pathtools3"
+VERSION="0.2.1"
+HOMEPAGE="https://pypi.org/project/pathtools3/"
+DOWNLOAD="https://files.pythonhosted.org/packages/38/19/b8e751fe76e98a04bdd34dd912230c24dd43f9908258f55e8c1062f2cd37/pathtools3-0.2.1.tar.gz"
+MD5SUM="08bb008161e305909740076c5c422159"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Prof. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/pathtools3/slack-desc b/python/pathtools3/slack-desc
new file mode 100644
index 0000000000..297dccf6eb
--- /dev/null
+++ b/python/pathtools3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pathtools3: pathtools3 (File system general utilities)
+pathtools3:
+pathtools3: Pattern matching and various utilities for file systems paths.
+pathtools3:
+pathtools3: Works on Python 2.7 and 3.4+. If you want to use an old version of
+pathtools3: Python, use pathtools < 0.1.2. https://pypi.org/project/pathtools/
+pathtools3:
+pathtools3:
+pathtools3:
+pathtools3: Homepage: https://pypi.org/project/pathtools3/
+pathtools3: