summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Prof. HORSTMANN2020-06-16 06:10:52 +0200
committer Willy Sudiarto Raharjo2020-06-20 02:59:27 +0200
commit61a98b970295ff33d1d63657e3b37ff6a413e74d (patch)
tree4ac2f403d60a3449d191e2ebf811431d850c561e /python
parent5486dac91c2b8231b47596551464b6fab6b6720d (diff)
downloadslackbuilds-61a98b970295ff33d1d63657e3b37ff6a413e74d.tar.gz
python/pysass: Added (python3 watch capability)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pysass/README5
-rw-r--r--python/pysass/pysass.SlackBuild74
-rw-r--r--python/pysass/pysass.info10
-rw-r--r--python/pysass/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/pysass/README b/python/pysass/README
new file mode 100644
index 0000000000..938829cca2
--- /dev/null
+++ b/python/pysass/README
@@ -0,0 +1,5 @@
+Sass CLI Python: A wrapper to libsass-python with watchdog capability.
+
+Add -w and --watch flags to pysassc command.
+Watch included directories and source directory recursively.
+Only watch *.scss files. Throttling.
diff --git a/python/pysass/pysass.SlackBuild b/python/pysass/pysass.SlackBuild
new file mode 100644
index 0000000000..4de9c92bc0
--- /dev/null
+++ b/python/pysass/pysass.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# SlackBuild build script for pysass
+
+# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=${PRGNAM:-pysass}
+SRCPKG=${SRCPKG-pysass}
+VERSION=${VERSION:-0.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $SRCPKG | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pysass/pysass.info b/python/pysass/pysass.info
new file mode 100644
index 0000000000..5b0807e02d
--- /dev/null
+++ b/python/pysass/pysass.info
@@ -0,0 +1,10 @@
+PRGNAM="pysass"
+VERSION="0.1.0"
+HOMEPAGE="https://pypi.org/project/pysass/"
+DOWNLOAD="https://files.pythonhosted.org/packages/bc/9c/b1661c74c79949fa5dce5c67d79339a2d2b4457d76ebc2d487cd5b417a96/pysass-0.1.0.tar.gz"
+MD5SUM="b54e9064102cbe40a1f75f8b7ffa9d4f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 watchdog BeautifulSoup4"
+MAINTAINER="Prof. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/pysass/slack-desc b/python/pysass/slack-desc
new file mode 100644
index 0000000000..f4f209e4d1
--- /dev/null
+++ b/python/pysass/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pysass: pysass (add watch capability)
+pysass:
+pysass: A simple wrapper on libsass-python pysassc to add watch capability
+pysass: using watchdog.
+pysass:
+pysass: Add -w and --watch flags to pysassc command.
+pysass: Watch included directories and source directory recursively.
+pysass: Only watch *.scss files. Throttling.
+pysass:
+pysass: Homepage: https://pypi.org/project/pysass/
+pysass: