summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2020-09-18 16:20:39 +0200
committer Willy Sudiarto Raharjo2020-09-19 03:55:02 +0200
commit44bccccee19f53a474f11679d783aad56d7ff6dc (patch)
treee8f143d24a3e1a706a47f4f0608d865fb5c7f825 /python
parentb35ab40baa3fbea359904e9bcc235be92ea8d727 (diff)
downloadslackbuilds-44bccccee19f53a474f11679d783aad56d7ff6dc.tar.gz
python/s3transfer: Added python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/s3transfer/README4
-rw-r--r--python/s3transfer/s3transfer.SlackBuild5
2 files changed, 9 insertions, 0 deletions
diff --git a/python/s3transfer/README b/python/s3transfer/README
index b684f98472..ddb6c15db8 100644
--- a/python/s3transfer/README
+++ b/python/s3transfer/README
@@ -1 +1,5 @@
S3transfer is a Python library for managing Amazon S3 transfers.
+
+Note: Dependency futures it does not work on Python 3,
+and Python 3 users do not need it as the concurrent.futures package
+is available in the standard library.
diff --git a/python/s3transfer/s3transfer.SlackBuild b/python/s3transfer/s3transfer.SlackBuild
index cf0405fdc2..695d9dbfcf 100644
--- a/python/s3transfer/s3transfer.SlackBuild
+++ b/python/s3transfer/s3transfer.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true