summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Yth - Arnaud2019-10-23 18:11:51 +0200
committer Willy Sudiarto Raharjo2019-10-23 18:11:51 +0200
commitc370cbb4c9aa63b5e7af1a8ad21aa7eda6b2fe27 (patch)
tree90dbc53130ef906cd106da9c4054ea996ad5ba25 /python
parenta2591c7b95bae39f1f75ba251b9a8bbf919d3d5a (diff)
downloadslackbuilds-c370cbb4c9aa63b5e7af1a8ad21aa7eda6b2fe27.tar.gz
python/repoze.lru: Added (LRU cache implementation and decorator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/repoze.lru/README1
-rw-r--r--python/repoze.lru/repoze.lru.SlackBuild69
-rw-r--r--python/repoze.lru/repoze.lru.info10
-rw-r--r--python/repoze.lru/slack-desc19
4 files changed, 99 insertions, 0 deletions
diff --git a/python/repoze.lru/README b/python/repoze.lru/README
new file mode 100644
index 0000000000..d5fc979cf4
--- /dev/null
+++ b/python/repoze.lru/README
@@ -0,0 +1 @@
+A tiny LRU cache implementation and decorator. \ No newline at end of file
diff --git a/python/repoze.lru/repoze.lru.SlackBuild b/python/repoze.lru/repoze.lru.SlackBuild
new file mode 100644
index 0000000000..f4bf941f63
--- /dev/null
+++ b/python/repoze.lru/repoze.lru.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# SlackBuild script for repoze.lru.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=repoze.lru
+VERSION=${VERSION:-0.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/repoze.lru/repoze.lru.info b/python/repoze.lru/repoze.lru.info
new file mode 100644
index 0000000000..5fce2c770e
--- /dev/null
+++ b/python/repoze.lru/repoze.lru.info
@@ -0,0 +1,10 @@
+PRGNAM="repoze.lru"
+VERSION="0.7"
+HOMEPAGE="http://www.repoze.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/r/repoze.lru/repoze.lru-0.7.tar.gz"
+MD5SUM="c08cc030387e0b1fc53c5c7d964b35e2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/repoze.lru/slack-desc b/python/repoze.lru/slack-desc
new file mode 100644
index 0000000000..800f854d2a
--- /dev/null
+++ b/python/repoze.lru/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+repoze.lru: repoze.lru (A tiny LRU cache implementation and decorator)
+repoze.lru:
+repoze.lru:
+repoze.lru:
+repoze.lru:
+repoze.lru:
+repoze.lru:
+repoze.lru:
+repoze.lru:
+repoze.lru:
+repoze.lru: