summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Jeremy Hansen2024-03-05 06:22:44 +0100
committer Willy Sudiarto Raharjo2024-03-05 06:35:05 +0100
commitd698d0df2a844b461558b7d7d4c019627eb4fa84 (patch)
treedb4c8dfe7501a032feb6a1f39d492040fe761d48 /python
parent8c6703c91920ca1689ca548afc81a5351a6cda0d (diff)
downloadslackbuilds-d698d0df2a844b461558b7d7d4c019627eb4fa84.tar.gz
python/python3-putio.py: Fix versioning issue
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-putio.py/python3-putio.py.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/python3-putio.py/python3-putio.py.SlackBuild b/python/python3-putio.py/python3-putio.py.SlackBuild
index db7c597e42..88e4b56767 100644
--- a/python/python3-putio.py/python3-putio.py.SlackBuild
+++ b/python/python3-putio.py/python3-putio.py.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-putio.py
SRCNAM=putio.py
VERSION=${VERSION:-8.7.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix building from source
+sed -i "s/'0'/\'$VERSION\'/" setup.py
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \