summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author isaackwy2024-03-02 08:44:53 +0100
committer Willy Sudiarto Raharjo2024-03-05 11:34:26 +0100
commit120fed9504c5f6b65b9d7e308b20b3a929fdd5ff (patch)
treea0e3c30f202805473c8fdaa6f6f5432e6401a856 /python
parent127c13e07c94d515f086be2744078664695d1758 (diff)
downloadslackbuilds-120fed9504c5f6b65b9d7e308b20b3a929fdd5ff.tar.gz
python/python3-pydocstyle: Update for 6.2.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pydocstyle/python3-pydocstyle.SlackBuild27
-rw-r--r--python/python3-pydocstyle/python3-pydocstyle.info8
2 files changed, 13 insertions, 22 deletions
diff --git a/python/python3-pydocstyle/python3-pydocstyle.SlackBuild b/python/python3-pydocstyle/python3-pydocstyle.SlackBuild
index 889a7f4e19..8f43b4b881 100644
--- a/python/python3-pydocstyle/python3-pydocstyle.SlackBuild
+++ b/python/python3-pydocstyle/python3-pydocstyle.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-pydocstyle
-# Copyright 2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pydocstyle
-VERSION=${VERSION:-6.1.1}
+VERSION=${VERSION:-6.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,13 +64,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Fix version number within metadata (code taken from the Arch Linux PKGBUILD):
+# https://gitlab.archlinux.org/archlinux/packaging/packages/python-pydocstyle/-/blob/main/PKGBUILD
+sed -e "s|^version = .*|version = \"$VERSION\"|" -i pyproject.toml
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE-MIT README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-pydocstyle/python3-pydocstyle.info b/python/python3-pydocstyle/python3-pydocstyle.info
index 40d9494d69..0ee2aa1a7e 100644
--- a/python/python3-pydocstyle/python3-pydocstyle.info
+++ b/python/python3-pydocstyle/python3-pydocstyle.info
@@ -1,10 +1,10 @@
PRGNAM="python3-pydocstyle"
-VERSION="6.1.1"
+VERSION="6.2.0"
HOMEPAGE="http://www.pydocstyle.org/"
-DOWNLOAD="https://github.com/PyCQA/pydocstyle/archive/6.1.1/pydocstyle-6.1.1.tar.gz"
-MD5SUM="0a1d4888fccdf1ecb1a8beb0fd87a0a6"
+DOWNLOAD="https://github.com/PyCQA/pydocstyle/archive/6.2.0/pydocstyle-6.2.0.tar.gz"
+MD5SUM="aa1ed3b326ffed8f4e857aa0f79bfa44"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="snowballstemmer"
+REQUIRES="python3-poetry-core snowballstemmer"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"