summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2021-10-12 20:10:32 +0200
committer Willy Sudiarto Raharjo2021-10-22 08:03:43 +0200
commitb6d5a8aa6f366c018e6578b97cff583c41d279b9 (patch)
tree83a35164635b7876f40bed94766bdb73b5aa153d /python
parentbf04767f83dfbe5422aa9d606dccbf0a029df77a (diff)
downloadslackbuilds-b6d5a8aa6f366c018e6578b97cff583c41d279b9.tar.gz
python/BeautifulSoup4: Updated for version 4.10.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.SlackBuild29
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.info8
2 files changed, 7 insertions, 30 deletions
diff --git a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 74338d9973..411127ea11 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=BeautifulSoup4
-VERSION=${VERSION:-4.9.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.10.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,30 +82,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
-
-# Python 3 support (requires python3-soupsieve)
-# shaypal5 provided an example package check:
-# https://gist.github.com/shaypal5/d505af9953cd86f59c750fa600ee4ba6
-if $(python3 -c 'import pkgutil; exit(not pkgutil.find_loader("soupsieve"))'); then
-
- # Prepare another source tarball before building for Python 3
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
- # Build for Python 3
- sed -i "s/-rfI/-rf/" convert-py3k
- sh convert-py3k
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/BeautifulSoup4/BeautifulSoup4.info b/python/BeautifulSoup4/BeautifulSoup4.info
index 7203506282..4093fcabeb 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.info
+++ b/python/BeautifulSoup4/BeautifulSoup4.info
@@ -1,10 +1,10 @@
PRGNAM="BeautifulSoup4"
-VERSION="4.9.3"
+VERSION="4.10.0"
HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/"
-DOWNLOAD="https://www.crummy.com/software/BeautifulSoup/bs4/download/4.9/beautifulsoup4-4.9.3.tar.gz"
-MD5SUM="57fd468ae3eb055f6871106e8f7813e2"
+DOWNLOAD="https://files.pythonhosted.org/packages/a1/69/daeee6d8f22c997e522cdbeb59641c4d31ab120aba0f2c799500f7456b7e/beautifulsoup4-4.10.0.tar.gz"
+MD5SUM="e754242642253dd31d249d00358d552e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-soupsieve python3-soupsieve"
+REQUIRES="python3-soupsieve"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"