summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2021-10-09 07:59:02 +0200
committer Willy Sudiarto Raharjo2021-10-09 11:21:32 +0200
commitb31be7bf861a1a0a03c662429bf93a210e9b4d60 (patch)
tree5f352d1fe89929bf73a0b6118f7e095a5e61b761 /python
parent51e616a81fff65a537202ed120a5b315937f988e (diff)
downloadslackbuilds-b31be7bf861a1a0a03c662429bf93a210e9b4d60.tar.gz
python/cryptography: Updated for version 35.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/cryptography/README6
-rw-r--r--python/cryptography/cryptography.SlackBuild9
-rw-r--r--python/cryptography/cryptography.info12
3 files changed, 11 insertions, 16 deletions
diff --git a/python/cryptography/README b/python/cryptography/README
index 343f01ac9a..c13567f6db 100644
--- a/python/cryptography/README
+++ b/python/cryptography/README
@@ -1,4 +1,2 @@
-cryptography is a Python library for Python 2.6+ & 3.2+
-which exposes cryptographic recipes and primitives.
-It's available under either the Apache Software License,
-Version 2.0, or the BSD license.
+cryptography is a Python library for 3.2+ which exposes cryptographic recipes and primitives.
+It's available under either the Apache Software License, Version 2.0, or the BSD license.
diff --git a/python/cryptography/cryptography.SlackBuild b/python/cryptography/cryptography.SlackBuild
index 022524be14..a2a609684d 100644
--- a/python/cryptography/cryptography.SlackBuild
+++ b/python/cryptography/cryptography.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for cryptography
# Copyright 2014-2018 Markus Reichelt, Aachen, DE
+# Copyright 2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,12 +23,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cryptography
-VERSION=${VERSION:-2.8}
+VERSION=${VERSION:-35.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,7 +78,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+sed -i '/install_requires/d' setup.py
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/cryptography/cryptography.info b/python/cryptography/cryptography.info
index a73ffc820c..3166ea1455 100644
--- a/python/cryptography/cryptography.info
+++ b/python/cryptography/cryptography.info
@@ -1,10 +1,10 @@
PRGNAM="cryptography"
-VERSION="2.8"
+VERSION="35.0.0"
HOMEPAGE="https://cryptography.io/"
-DOWNLOAD="https://files.pythonhosted.org/packages/be/60/da377e1bed002716fb2d5d1d1cab720f298cb33ecff7bf7adea72788e4e4/cryptography-2.8.tar.gz"
-MD5SUM="77730058b556c6d9838679a94c6229ce"
+DOWNLOAD="https://files.pythonhosted.org/packages/be/60/da377e1bed002716fb2d5d1d1cab720f35.0.0cb33ecff7bf7adea735.0.08e4e4/cryptography-35.0.0.tar.gz"
+MD5SUM="ba34eba3ae36cbf3d2e1ee3239f07732"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pyasn1 cffi ipaddress asn1crypto wheel"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
+REQUIRES="pyasn1 asn1crypto wheel python3-setuptools-rust"
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackbuilds.org"