summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2021-02-10 02:19:29 +0100
committer Willy Sudiarto Raharjo2021-02-14 00:27:51 +0100
commiteaed60098d5addbb05dfb804a5050db19a926b3b (patch)
tree27d97d9eac2afa6a045f092f3b95393519b2da46 /python
parentf34051d76cb1c62f4fee0cd0fc5305d4f4e02617 (diff)
downloadslackbuilds-eaed60098d5addbb05dfb804a5050db19a926b3b.tar.gz
python/python-zipp: Fixed missing version in setup.cfg.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-zipp/README3
-rw-r--r--python/python-zipp/python-zipp.SlackBuild4
2 files changed, 5 insertions, 2 deletions
diff --git a/python/python-zipp/README b/python/python-zipp/README
index 995ffb6ef9..6498203e6d 100644
--- a/python/python-zipp/README
+++ b/python/python-zipp/README
@@ -1 +1,2 @@
-A pathlib-compatible Zipfile object wrapper. A backport of the Path object.
+A pathlib-compatible Zipfile object wrapper. A backport of the Path
+object.
diff --git a/python/python-zipp/python-zipp.SlackBuild b/python/python-zipp/python-zipp.SlackBuild
index 79c3e5f2ac..4622558c71 100644
--- a/python/python-zipp/python-zipp.SlackBuild
+++ b/python/python-zipp/python-zipp.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python-zipp
VERSION=${VERSION:-2.2.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
SRCNAM=zipp
@@ -71,6 +71,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s,^name =.*$,&\nversion = $VERSION," setup.cfg
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \