summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Leo C2019-12-14 23:26:17 +0100
committer Willy Sudiarto Raharjo2019-12-14 23:26:17 +0100
commit6ce8821f7a0235e2efe8a133817e853530d5ae5b (patch)
tree191b3be3ac7435530db61dbc502be9cd61cfc1d6 /python
parente48b2464b46743d3c5eedd3226b69326f18c9d17 (diff)
downloadslackbuilds-6ce8821f7a0235e2efe8a133817e853530d5ae5b.tar.gz
python/python-iso639: Added (ISO 639 library for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-iso639/README6
-rw-r--r--python/python-iso639/python-iso639.SlackBuild92
-rw-r--r--python/python-iso639/python-iso639.info10
-rw-r--r--python/python-iso639/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/python/python-iso639/README b/python/python-iso639/README
new file mode 100644
index 0000000000..d960a6ea74
--- /dev/null
+++ b/python/python-iso639/README
@@ -0,0 +1,6 @@
+python-iso639 is a Python library for the ISO 639 standard.
+It supports ISO 639-1 for two-letter language codes, ISO 639-2 and
+ISO 639-3 for three-letter language codes, and ISO 639-5 for language
+group codes.
+
+Python3 is an optional dependency.
diff --git a/python/python-iso639/python-iso639.SlackBuild b/python/python-iso639/python-iso639.SlackBuild
new file mode 100644
index 0000000000..b5a2f4d0ee
--- /dev/null
+++ b/python/python-iso639/python-iso639.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python-iso639
+
+# Copyright 2019 Leonardo Citrolo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-iso639
+SRCNAM=${SRCNAM:-iso639}
+VERSION=${VERSION:-0.4.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst INSTALL.rst LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-iso639/python-iso639.info b/python/python-iso639/python-iso639.info
new file mode 100644
index 0000000000..c26199add0
--- /dev/null
+++ b/python/python-iso639/python-iso639.info
@@ -0,0 +1,10 @@
+PRGNAM="python-iso639"
+VERSION="0.4.5"
+HOMEPAGE="https://github.com/noumar/iso639"
+DOWNLOAD="https://github.com/noumar/iso639/archive/0.4.5/iso639-0.4.5.tar.gz"
+MD5SUM="4ecf572a2a14f628f141deb4d257827b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Leo C."
+EMAIL="leoc@gmx.com"
diff --git a/python/python-iso639/slack-desc b/python/python-iso639/slack-desc
new file mode 100644
index 0000000000..90b4906021
--- /dev/null
+++ b/python/python-iso639/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-iso639: python-iso639 (ISO 639 library for Python)
+python-iso639:
+python-iso639: python-iso639 is a Python library for the ISO 639 standard.
+python-iso639: It supports ISO 639-1 for two-letter language codes, ISO 639-2 and
+python-iso639: ISO 639-3 for three-letter language codes, and ISO 639-5 for language
+python-iso639: group codes.
+python-iso639:
+python-iso639:
+python-iso639:
+python-iso639: Homepage: https://github.com/noumar/iso639
+python-iso639: