summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu2019-03-31 03:55:07 +0200
committer Willy Sudiarto Raharjo2019-03-31 03:55:07 +0200
commitadf7d90b5514a91cbe93a64e7e5e21a9eb1fe371 (patch)
tree32a1e82f4ca757cc0b1b0d9d69b9c0a4ec4b9212 /python
parent59ac6dc064ead90af21f84615184d6ac3c25153e (diff)
downloadslackbuilds-adf7d90b5514a91cbe93a64e7e5e21a9eb1fe371.tar.gz
python/python3-aiohttp: Added (HTTP client/server for asyncio).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-aiohttp/README1
-rw-r--r--python/python3-aiohttp/python3-aiohttp.SlackBuild85
-rw-r--r--python/python3-aiohttp/python3-aiohttp.info10
-rw-r--r--python/python3-aiohttp/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python3-aiohttp/README b/python/python3-aiohttp/README
new file mode 100644
index 0000000000..6cb3cbc966
--- /dev/null
+++ b/python/python3-aiohttp/README
@@ -0,0 +1 @@
+AIOHTTP is an asynchronous HTTP client/server framework for asyncio.
diff --git a/python/python3-aiohttp/python3-aiohttp.SlackBuild b/python/python3-aiohttp/python3-aiohttp.SlackBuild
new file mode 100644
index 0000000000..f48f3f86f2
--- /dev/null
+++ b/python/python3-aiohttp/python3-aiohttp.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for python3-aiohttp
+# Copyright 2019 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-aiohttp
+SRCNAM=aiohttp
+VERSION=${VERSION:-3.5.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst *.txt docs/ requirements/ CODE_OF_CONDUCT.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz} \ No newline at end of file
diff --git a/python/python3-aiohttp/python3-aiohttp.info b/python/python3-aiohttp/python3-aiohttp.info
new file mode 100644
index 0000000000..f96fcd081a
--- /dev/null
+++ b/python/python3-aiohttp/python3-aiohttp.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-aiohttp"
+VERSION="3.5.4"
+HOMEPAGE="https://aiohttp.readthedocs.io/en/stable/"
+DOWNLOAD="https://github.com/aio-libs/aiohttp/archive/v3.5.4/aiohttp-3.5.4.tar.gz"
+MD5SUM="7a152f5236ee3b3ef97b6f1965a7c62c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gunicorn async-timeout python3-attrs yarl"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-aiohttp/slack-desc b/python/python3-aiohttp/slack-desc
new file mode 100644
index 0000000000..9d56630212
--- /dev/null
+++ b/python/python3-aiohttp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-aiohttp: python3-aiohttp (HTTP client/server for asyncio)
+python3-aiohttp:
+python3-aiohttp: AIOHTTP is an asynchronous HTTP client/server framework for asyncio.
+python3-aiohttp:
+python3-aiohttp:
+python3-aiohttp:
+python3-aiohttp:
+python3-aiohttp:
+python3-aiohttp:
+python3-aiohttp:
+python3-aiohttp: