summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons2018-09-13 04:01:11 +0200
committer Willy Sudiarto Raharjo2018-11-17 12:31:49 +0100
commit8bf496d58172e1c46b1e7ad66fef2c0098fad23d (patch)
tree811605397d05de44a17b27df9efe06dbd810aee9 /python
parent4163153d1ac9b7bd439650e4b0110d6e2367f8a5 (diff)
downloadslackbuilds-8bf496d58172e1c46b1e7ad66fef2c0098fad23d.tar.gz
python/pyOpenSSL: Add support for python3.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyOpenSSL/pyOpenSSL.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/pyOpenSSL/pyOpenSSL.SlackBuild b/python/pyOpenSSL/pyOpenSSL.SlackBuild
index 0e041f8b07..06196274ae 100644
--- a/python/pyOpenSSL/pyOpenSSL.SlackBuild
+++ b/python/pyOpenSSL/pyOpenSSL.SlackBuild
@@ -76,6 +76,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true