summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy2022-05-20 05:33:37 +0200
committer Willy Sudiarto Raharjo2022-05-21 03:25:19 +0200
commitc7eea6b3bcbe13936d4ab86af5bb87e1c30d3f6d (patch)
tree65490f73da6dc26e72ba09b0ed92df2711b88136 /python
parent8f62ad1026170db3836af1efce2c65759f03b0b7 (diff)
downloadslackbuilds-c7eea6b3bcbe13936d4ab86af5bb87e1c30d3f6d.tar.gz
python/dfwinreg: Updated for version 20211207.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/dfwinreg/dfwinreg.SlackBuild8
-rw-r--r--python/dfwinreg/dfwinreg.info8
2 files changed, 8 insertions, 8 deletions
diff --git a/python/dfwinreg/dfwinreg.SlackBuild b/python/dfwinreg/dfwinreg.SlackBuild
index 5c383e16b4..4ecaf70cdb 100644
--- a/python/dfwinreg/dfwinreg.SlackBuild
+++ b/python/dfwinreg/dfwinreg.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for dfwinreg
-# Copyright 2017-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2017-2022 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated to version 20190122, March 2019
+# Updated to version 20211207 May 2022
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dfwinreg
-VERSION=${VERSION:-20190122}
+VERSION=${VERSION:-20211207}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/dfwinreg/dfwinreg.info b/python/dfwinreg/dfwinreg.info
index 1cb7f85366..2c14ef32b3 100644
--- a/python/dfwinreg/dfwinreg.info
+++ b/python/dfwinreg/dfwinreg.info
@@ -1,10 +1,10 @@
PRGNAM="dfwinreg"
-VERSION="20190122"
+VERSION="20211207"
HOMEPAGE="https://github.com/log2timeline/dfwinreg"
-DOWNLOAD="https://slackware.uk/sbosrcarch/by-md5/3/2/328a6b366425d205483b43b95c95ca60/dfwinreg-20190122.tar.gz"
-MD5SUM="328a6b366425d205483b43b95c95ca60"
+DOWNLOAD="https://linuxleo.com/Source/dfwinreg-20211207.tar.gz"
+MD5SUM="6756c10adbce619ed331bcf026fdb214"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-PyYAML dfdatetime dtfabric libregf"
+REQUIRES="dfdatetime dtfabric libregf libcreg"
MAINTAINER="Barry J. Grundy"
EMAIL="bgrundy<at>linuxleo.com"