summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-12-28 03:20:20 +0100
committer Willy Sudiarto Raharjo2019-12-28 03:20:20 +0100
commitaefe4cb123e64ffefc797212cb1f55cd373e7562 (patch)
tree19e06e70ef908462369dbfd2355484a14dbceb4a /python
parent5dd637ad40c493ed449dd3c25729daf636331b03 (diff)
downloadslackbuilds-aefe4cb123e64ffefc797212cb1f55cd373e7562.tar.gz
python/Flask-Dance: Added (Doing the OAuth using Flask).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/Flask-Dance/Flask-Dance.SlackBuild88
-rw-r--r--python/Flask-Dance/Flask-Dance.info10
-rw-r--r--python/Flask-Dance/README4
-rw-r--r--python/Flask-Dance/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/Flask-Dance/Flask-Dance.SlackBuild b/python/Flask-Dance/Flask-Dance.SlackBuild
new file mode 100644
index 0000000000..3b26bbca6d
--- /dev/null
+++ b/python/Flask-Dance/Flask-Dance.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for Flask-Dance
+
+# Copyright 2019 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Flask-Dance
+VERSION=${VERSION:-3.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# fix path for requirements.txt file
+sed -i "s/tests\///" setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE CHANGELOG.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Flask-Dance/Flask-Dance.info b/python/Flask-Dance/Flask-Dance.info
new file mode 100644
index 0000000000..65fef77803
--- /dev/null
+++ b/python/Flask-Dance/Flask-Dance.info
@@ -0,0 +1,10 @@
+PRGNAM="Flask-Dance"
+VERSION="3.0.0"
+HOMEPAGE="https://github.com/singingwolfboy/flask-dance"
+DOWNLOAD="https://files.pythonhosted.org/packages/e4/1b/14e319de35a7680db7ae189d883d4c11448807ae0f246f2b9d808d6b101e/Flask-Dance-3.0.0.tar.gz"
+MD5SUM="794db1b65dbb5221644a6ff5c201548d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-Flask requests-oauthlib URLObject python3-six"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/Flask-Dance/README b/python/Flask-Dance/README
new file mode 100644
index 0000000000..b339d9bce7
--- /dev/null
+++ b/python/Flask-Dance/README
@@ -0,0 +1,4 @@
+Doing the OAuth dance with style using Flask, requests,
+and oauthlib. Currently, only OAuth consumers are supported,
+but this project could easily support OAuth providers
+in the future, as well.
diff --git a/python/Flask-Dance/slack-desc b/python/Flask-Dance/slack-desc
new file mode 100644
index 0000000000..a68e6f3e90
--- /dev/null
+++ b/python/Flask-Dance/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Flask-Dance: Flask-Dance (Doing the OAuth using Flask)
+Flask-Dance:
+Flask-Dance: Doing the OAuth dance with style using Flask, requests,
+Flask-Dance: and oauthlib. Currently, only OAuth consumers are supported,
+Flask-Dance: but this project could easily support OAuth providers
+Flask-Dance: in the future, as well.
+Flask-Dance:
+Flask-Dance: Homepage: https://github.com/singingwolfboy/flask-dance
+Flask-Dance:
+Flask-Dance:
+Flask-Dance: