summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-06-07 14:34:11 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:33:16 +0200
commitfa33224244deb63dc40b1db5b1c6b9a9f6d16c1d (patch)
tree78642d2c242da9b9a62a2a31e75dac0a1c411bb9 /python
parent24413e5cdcde81e9ad22d29d5bf2f273c076430f (diff)
downloadslackbuilds-fa33224244deb63dc40b1db5b1c6b9a9f6d16c1d.tar.gz
python/pickleshare: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/pickleshare/pickleshare.SlackBuild7
-rw-r--r--python/pickleshare/pickleshare.info2
2 files changed, 5 insertions, 4 deletions
diff --git a/python/pickleshare/pickleshare.SlackBuild b/python/pickleshare/pickleshare.SlackBuild
index a6c1061592..99a854da62 100644
--- a/python/pickleshare/pickleshare.SlackBuild
+++ b/python/pickleshare/pickleshare.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pickleshare
-# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pickleshare
VERSION=${VERSION:-0.7.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pickleshare/pickleshare.info b/python/pickleshare/pickleshare.info
index 163fb8315c..c1ba645861 100644
--- a/python/pickleshare/pickleshare.info
+++ b/python/pickleshare/pickleshare.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/pickleshare/pickleshare/archive/0.7.5/pickleshare-0
MD5SUM="79387de9fd8cc26e29d5cae9fc2fab9d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pathlib"
+REQUIRES="pathlib python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"