summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-05-31 04:39:58 +0200
committer Willy Sudiarto Raharjo2019-06-01 02:04:25 +0200
commitf253b7ec7df0df32efb81b89f1a57cc16dde2e91 (patch)
treed1b3430efae965e0d9035e3bf239711a5e144922 /python
parentbcbd6503c7a55dc19ac3bfe8598b2e9584658cfa (diff)
downloadslackbuilds-f253b7ec7df0df32efb81b89f1a57cc16dde2e91.tar.gz
python/python3-decorator: Removed (merged with python/decorator).
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/python3-decorator/README4
-rw-r--r--python/python3-decorator/python3-decorator.SlackBuild72
-rw-r--r--python/python3-decorator/python3-decorator.info10
-rw-r--r--python/python3-decorator/slack-desc19
4 files changed, 0 insertions, 105 deletions
diff --git a/python/python3-decorator/README b/python/python3-decorator/README
deleted file mode 100644
index d1d2a840af..0000000000
--- a/python/python3-decorator/README
+++ /dev/null
@@ -1,4 +0,0 @@
-The aim of the decorator module it to simplify the usage of decorators
-for the average programmer, and to popularize decorators usage giving
-examples of useful decorators, such as memoize, tracing,
-redirecting_stdout, locked, etc.
diff --git a/python/python3-decorator/python3-decorator.SlackBuild b/python/python3-decorator/python3-decorator.SlackBuild
deleted file mode 100644
index 2604c5dba0..0000000000
--- a/python/python3-decorator/python3-decorator.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-decorator
-
-# Copyright 2013 Mikko Värri, Finland
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=decorator
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-4.4.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES.md LICENSE.txt README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-decorator/python3-decorator.info b/python/python3-decorator/python3-decorator.info
deleted file mode 100644
index 841dfb6227..0000000000
--- a/python/python3-decorator/python3-decorator.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-decorator"
-VERSION="4.4.0"
-HOMEPAGE="https://pypi.python.org/pypi/decorator"
-DOWNLOAD="https://github.com/micheles/decorator/archive/4.4.0/decorator-4.4.0.tar.gz"
-MD5SUM="bf924abe09417f95a470017ae2bc5230"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-decorator/slack-desc b/python/python3-decorator/slack-desc
deleted file mode 100644
index 94612e88d5..0000000000
--- a/python/python3-decorator/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-decorator: python3-decorator (decorator module for Python 3)
-python3-decorator:
-python3-decorator: The aim of the decorator module it to simplify the usage of
-python3-decorator: decorators for the average programmer, and to popularize decorators
-python3-decorator: usage giving examples of useful decorators, such as memoize, tracing,
-python3-decorator: redirecting_stdout, locked, etcetera.
-python3-decorator:
-python3-decorator: https://pypi.python.org/pypi/decorator
-python3-decorator:
-python3-decorator:
-python3-decorator: