summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-06-07 18:50:49 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:33:17 +0200
commitd7a16937e876e4883e3b7d9f98192235055b483b (patch)
tree619aeaae87fb75d17509888093e87d28fbda0f31 /python
parent34f1bddcafd42cd8cdfe8e481a059abcfa44b37f (diff)
downloadslackbuilds-d7a16937e876e4883e3b7d9f98192235055b483b.tar.gz
python/python3-parso: Removed (merged with python/parso).
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/python3-parso/README8
-rw-r--r--python/python3-parso/python3-parso.SlackBuild88
-rw-r--r--python/python3-parso/python3-parso.info10
-rw-r--r--python/python3-parso/slack-desc19
4 files changed, 0 insertions, 125 deletions
diff --git a/python/python3-parso/README b/python/python3-parso/README
deleted file mode 100644
index 77f72ea9f5..0000000000
--- a/python/python3-parso/README
+++ /dev/null
@@ -1,8 +0,0 @@
-Parso is a Python parser that supports error recovery and round-trip parsing
-for different Python versions (in multiple Python versions). Parso is also able
-to list multiple syntax errors in your python file.
-
-Parso has been battle-tested by jedi. It was pulled out of jedi to be useful
-for other projects as well.
-
-Parso consists of a small API to parse Python and analyse the syntax tree.
diff --git a/python/python3-parso/python3-parso.SlackBuild b/python/python3-parso/python3-parso.SlackBuild
deleted file mode 100644
index 627c2af408..0000000000
--- a/python/python3-parso/python3-parso.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-parso
-
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=parso
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-0.4.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS.txt CHANGELOG.rst CONTRIBUTING.md LICENSE.txt README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-parso/python3-parso.info b/python/python3-parso/python3-parso.info
deleted file mode 100644
index 8aca36e1a5..0000000000
--- a/python/python3-parso/python3-parso.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-parso"
-VERSION="0.4.0"
-HOMEPAGE="https://github.com/davidhalter/parso"
-DOWNLOAD="https://github.com/davidhalter/parso/archive/v0.4.0/parso-0.4.0.tar.gz"
-MD5SUM="721c1d9bd98e9d58869f14d595382b72"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-parso/slack-desc b/python/python3-parso/slack-desc
deleted file mode 100644
index 2b97ca9177..0000000000
--- a/python/python3-parso/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-parso: python3-parso (Python parser)
-python3-parso:
-python3-parso: Parso is a Python parser that supports error recovery and round-trip
-python3-parso: parsing for different Python versions (in multiple Python versions).
-python3-parso: Parso is also able to list multiple syntax errors in your python file.
-python3-parso:
-python3-parso:
-python3-parso:
-python3-parso:
-python3-parso:
-python3-parso: