summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Thibaut Notteboom2019-05-24 19:39:53 +0200
committer Willy Sudiarto Raharjo2019-05-25 02:31:50 +0200
commit979740c4bb6d3e5f12d5fa99f2b474de4c6b1c33 (patch)
tree359191137ce7d0c768c52180cac6290c0cb79d23 /python
parent410552a89c8c7eb9eabb156b42ac158e4a5c6bf4 (diff)
downloadslackbuilds-979740c4bb6d3e5f12d5fa99f2b474de4c6b1c33.tar.gz
python/python-requests: Updated for version 2.22.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-requests/README2
-rw-r--r--python/python-requests/python-requests.SlackBuild8
-rw-r--r--python/python-requests/python-requests.info8
-rw-r--r--python/python-requests/support-urllib3-1.26.patch40
4 files changed, 8 insertions, 50 deletions
diff --git a/python/python-requests/README b/python/python-requests/README
index 9cf8a1867d..5f015336cd 100644
--- a/python/python-requests/README
+++ b/python/python-requests/README
@@ -1,4 +1,4 @@
Requests is an Apache2 Licensed HTTP library, written in Python, for
human beings.
-python3 is an optional dependency (autodetected).
+python3 and python3-certifi are optional dependencies (autodetected).
diff --git a/python/python-requests/python-requests.SlackBuild b/python/python-requests/python-requests.SlackBuild
index ec176dbfdb..737c26a98e 100644
--- a/python/python-requests/python-requests.SlackBuild
+++ b/python/python-requests/python-requests.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-requests
-# Copyright 2013-2018 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2013-2019 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-requests
-VERSION=${VERSION:-2.21.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.22.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCNAM=requests
@@ -71,8 +71,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/support-urllib3-1.26.patch
-
python setup.py install --root=$PKG
# Python 3 support.
diff --git a/python/python-requests/python-requests.info b/python/python-requests/python-requests.info
index 549c647a0d..a0833bec26 100644
--- a/python/python-requests/python-requests.info
+++ b/python/python-requests/python-requests.info
@@ -1,8 +1,8 @@
PRGNAM="python-requests"
-VERSION="2.21.0"
-HOMEPAGE="http://python-requests.org/"
-DOWNLOAD="https://github.com/kennethreitz/requests/archive/v2.21.0/requests-2.21.0.tar.gz"
-MD5SUM="cc0945656d97368367ce893d5834035a"
+VERSION="2.22.0"
+HOMEPAGE="https://2.python-requests.org"
+DOWNLOAD="https://github.com/kennethreitz/requests/archive/v2.22.0/requests-2.22.0.tar.gz"
+MD5SUM="b32e3383fbcd173e515883b6631a2eed"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python-certifi python-chardet idna python-urllib3"
diff --git a/python/python-requests/support-urllib3-1.26.patch b/python/python-requests/support-urllib3-1.26.patch
deleted file mode 100644
index de0bb11dbd..0000000000
--- a/python/python-requests/support-urllib3-1.26.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From d6b5b401e8d6141bcefa4a70ff1c836aa085120b Mon Sep 17 00:00:00 2001
-From: Nate Prewitt <Nate.Prewitt@gmail.com>
-Date: Thu, 25 Apr 2019 10:05:02 -0700
-Subject: [PATCH] upgrade support for urllib3 1.25
-
----
- requests/__init__.py | 4 ++--
- setup.py | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/requests/__init__.py b/requests/__init__.py
-index bc168ee53..9a899df67 100644
---- a/requests/__init__.py
-+++ b/requests/__init__.py
-@@ -57,10 +57,10 @@ def check_compatibility(urllib3_version, chardet_version):
- # Check urllib3 for compatibility.
- major, minor, patch = urllib3_version # noqa: F811
- major, minor, patch = int(major), int(minor), int(patch)
-- # urllib3 >= 1.21.1, <= 1.24
-+ # urllib3 >= 1.21.1, <= 1.25
- assert major == 1
- assert minor >= 21
-- assert minor <= 24
-+ assert minor <= 25
-
- # Check chardet for compatibility.
- major, minor, patch = chardet_version.split('.')[:3]
-diff --git a/setup.py b/setup.py
-index 10ce2c621..50925533e 100755
---- a/setup.py
-+++ b/setup.py
-@@ -44,7 +44,7 @@ def run_tests(self):
- requires = [
- 'chardet>=3.0.2,<3.1.0',
- 'idna>=2.5,<2.9',
-- 'urllib3>=1.21.1,<1.25',
-+ 'urllib3>=1.21.1,<1.26,!=1.25.0',
- 'certifi>=2017.4.17'
-
- ]