summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-06-07 23:15:29 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:33:17 +0200
commit821b62031b846dd8a345278d504cc61f9ee9f428 (patch)
tree67af8247c0bb8423c43db2daa42cea6bce2b907b /python
parent1ed9bcfa02ed6ea73ea8bee6731ff5abd446e3ed (diff)
downloadslackbuilds-821b62031b846dd8a345278d504cc61f9ee9f428.tar.gz
python/python3-jupyter_core: Removed.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/python3-jupyter_core/README2
-rw-r--r--python/python3-jupyter_core/python3-jupyter_core.SlackBuild86
-rw-r--r--python/python3-jupyter_core/python3-jupyter_core.info10
-rw-r--r--python/python3-jupyter_core/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/python/python3-jupyter_core/README b/python/python3-jupyter_core/README
deleted file mode 100644
index 0760bba3fa..0000000000
--- a/python/python3-jupyter_core/README
+++ /dev/null
@@ -1,2 +0,0 @@
-The Jupyter core contains the base application classes and configuration used
-by other Jupyter projects.
diff --git a/python/python3-jupyter_core/python3-jupyter_core.SlackBuild b/python/python3-jupyter_core/python3-jupyter_core.SlackBuild
deleted file mode 100644
index f8cb2b5d1c..0000000000
--- a/python/python3-jupyter_core/python3-jupyter_core.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-jupyter_core
-
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=jupyter_core
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-4.4.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-jupyter_core/python3-jupyter_core.info b/python/python3-jupyter_core/python3-jupyter_core.info
deleted file mode 100644
index 1a1f550a41..0000000000
--- a/python/python3-jupyter_core/python3-jupyter_core.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-jupyter_core"
-VERSION="4.4.0"
-HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/jupyter/jupyter_core/archive/4.4.0/jupyter_core-4.4.0.tar.gz"
-MD5SUM="f2bdb8be2959d3043b77508dd6498687"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-jupyter_core/slack-desc b/python/python3-jupyter_core/slack-desc
deleted file mode 100644
index 12bb892aaa..0000000000
--- a/python/python3-jupyter_core/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-jupyter_core: python3-jupyter_core (core common functionality of Jupyter projects)
-python3-jupyter_core:
-python3-jupyter_core: The Jupyter core contains the base application classes and
-python3-jupyter_core: configuration used by other Jupyter projects.
-python3-jupyter_core:
-python3-jupyter_core:
-python3-jupyter_core:
-python3-jupyter_core:
-python3-jupyter_core:
-python3-jupyter_core:
-python3-jupyter_core: