summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-06-07 14:29:05 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:33:16 +0200
commit1513e79cc20ae10d581d5240d80c7774e78becb3 (patch)
tree3ca525d84b40af5b8928127ed18e2bd18b0bd82f /python
parentded9df5055268a9b2e8a682497b3a2ab1ab114eb (diff)
downloadslackbuilds-1513e79cc20ae10d581d5240d80c7774e78becb3.tar.gz
python/traitlets: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/traitlets/traitlets.SlackBuild7
-rw-r--r--python/traitlets/traitlets.info2
2 files changed, 5 insertions, 4 deletions
diff --git a/python/traitlets/traitlets.SlackBuild b/python/traitlets/traitlets.SlackBuild
index 0a32158723..6ade4f16c9 100644
--- a/python/traitlets/traitlets.SlackBuild
+++ b/python/traitlets/traitlets.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for traitlets
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=traitlets
VERSION=${VERSION:-4.3.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/traitlets/traitlets.info b/python/traitlets/traitlets.info
index 09f1cb170a..500e8e5ad1 100644
--- a/python/traitlets/traitlets.info
+++ b/python/traitlets/traitlets.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/ipython/traitlets/archive/4.3.2/traitlets-4.3.2.tar
MD5SUM="0b5b7986aef676d12f31a16cbbe3ed92"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="enum34 ipython_genutils six"
+REQUIRES="enum34 ipython_genutils six python3-six"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"