summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-06-07 23:19:00 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:33:17 +0200
commit055c92c93c1af7f23c7561ddc943aaa07c729380 (patch)
treee6d5c37db09c2ad084360c3c6ce94160a208f849 /python
parentcd6fbadd8cd4467f2f9a2ac2325ede10c378f58c (diff)
downloadslackbuilds-055c92c93c1af7f23c7561ddc943aaa07c729380.tar.gz
python/python3-jupyter_client: Removed.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/python3-jupyter_client/README2
-rw-r--r--python/python3-jupyter_client/python3-jupyter_client.SlackBuild86
-rw-r--r--python/python3-jupyter_client/python3-jupyter_client.info10
-rw-r--r--python/python3-jupyter_client/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/python/python3-jupyter_client/README b/python/python3-jupyter_client/README
deleted file mode 100644
index 9a671539dc..0000000000
--- a/python/python3-jupyter_client/README
+++ /dev/null
@@ -1,2 +0,0 @@
-jupyter_client contains the reference implementation of the Jupyter protocol.
-It also provides client and kernel management APIs for working with kernels.
diff --git a/python/python3-jupyter_client/python3-jupyter_client.SlackBuild b/python/python3-jupyter_client/python3-jupyter_client.SlackBuild
deleted file mode 100644
index 839b478342..0000000000
--- a/python/python3-jupyter_client/python3-jupyter_client.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-jupyter_client
-
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=jupyter_client
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-5.2.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-jupyter_client/python3-jupyter_client.info b/python/python3-jupyter_client/python3-jupyter_client.info
deleted file mode 100644
index 38bca50943..0000000000
--- a/python/python3-jupyter_client/python3-jupyter_client.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-jupyter_client"
-VERSION="5.2.4"
-HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/jupyter/jupyter_client/archive/5.2.4/jupyter_client-5.2.4.tar.gz"
-MD5SUM="75bee0a29c81d157fa2cc2de0870eed2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-dateutil decorator python3-jupyter_core python3-pyzmq traitlets"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-jupyter_client/slack-desc b/python/python3-jupyter_client/slack-desc
deleted file mode 100644
index 3cac58ed19..0000000000
--- a/python/python3-jupyter_client/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-jupyter_client: python3-jupyter_client (Jupyter protocol client APIs for Python 3)
-python3-jupyter_client:
-python3-jupyter_client: jupyter_client contains the reference implementation of the Jupyter
-python3-jupyter_client: protocol. It also provides client and kernel management APIs for
-python3-jupyter_client: working with kernels.
-python3-jupyter_client:
-python3-jupyter_client:
-python3-jupyter_client:
-python3-jupyter_client:
-python3-jupyter_client:
-python3-jupyter_client: