summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Markus Rinne2018-06-28 23:40:19 +0200
committer David Spencer2018-06-28 23:40:19 +0200
commitda921ab25ea00aea84128dceb008546a2b01b573 (patch)
tree941252aab80839a95567fc6d921ffb4801ad0a97 /python
parent2a7df0d5879bf600f54d352af3108b57b5e37d01 (diff)
downloadslackbuilds-da921ab25ea00aea84128dceb008546a2b01b573.tar.gz
python/python3-setuptools_autover: Added (version number generator).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-setuptools_autover/README4
-rw-r--r--python/python3-setuptools_autover/python3-setuptools_autover.SlackBuild88
-rw-r--r--python/python3-setuptools_autover/python3-setuptools_autover.info10
-rw-r--r--python/python3-setuptools_autover/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/python3-setuptools_autover/README b/python/python3-setuptools_autover/README
new file mode 100644
index 0000000000..396d74cd09
--- /dev/null
+++ b/python/python3-setuptools_autover/README
@@ -0,0 +1,4 @@
+A package allowing generating PEP-440 compatible version numbers from version
+control. Currently only git is supported. Provides reasonable defaults and
+an easy way to customize how version numbers are generated from version
+control system.
diff --git a/python/python3-setuptools_autover/python3-setuptools_autover.SlackBuild b/python/python3-setuptools_autover/python3-setuptools_autover.SlackBuild
new file mode 100644
index 0000000000..f6373028dc
--- /dev/null
+++ b/python/python3-setuptools_autover/python3-setuptools_autover.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for python3-setuptools_autover
+
+# Copyright 2018 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-setuptools_autover
+SRCNAM=setuptools_autover
+VERSION=${VERSION:-1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-setuptools_autover/python3-setuptools_autover.info b/python/python3-setuptools_autover/python3-setuptools_autover.info
new file mode 100644
index 0000000000..20aafae326
--- /dev/null
+++ b/python/python3-setuptools_autover/python3-setuptools_autover.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-setuptools_autover"
+VERSION="1.0"
+HOMEPAGE="https://github.com/jannero/setuptools_autover"
+DOWNLOAD="https://files.pythonhosted.org/packages/8f/8b/aa1e4f1cf3aaaeace4b64d288b0d9d995a362da8d36e7e8087dd181c1995/setuptools_autover-1.0.tar.gz"
+MD5SUM="575139b658694e4900d5544d60ccc266"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"
diff --git a/python/python3-setuptools_autover/slack-desc b/python/python3-setuptools_autover/slack-desc
new file mode 100644
index 0000000000..6aaf757201
--- /dev/null
+++ b/python/python3-setuptools_autover/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-setuptools_autover: python3-setuptools_autover (version number generator for setuptools)
+python3-setuptools_autover:
+python3-setuptools_autover: A package allowing generating PEP-440 compatible version numbers from
+python3-setuptools_autover: version control. Currently only git is supported. Provides
+python3-setuptools_autover: reasonable defaults and an easy way to customize how version numbers
+python3-setuptools_autover: are generated from version control system.
+python3-setuptools_autover:
+python3-setuptools_autover:
+python3-setuptools_autover:
+python3-setuptools_autover:
+python3-setuptools_autover: