summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-06-30 19:05:52 +0200
committer Willy Sudiarto Raharjo2018-07-07 01:54:11 +0200
commit79b7a838f9da913234e2d270c02a3cc66d2fe977 (patch)
tree9ce3d19ea6d91bae1d161b73782b02ca3bc8e0e0 /python
parent7c0948c2f0978db4fb2d1c39b568ef64ec87fed8 (diff)
downloadslackbuilds-79b7a838f9da913234e2d270c02a3cc66d2fe977.tar.gz
python/ptyprocess: Updated for version 0.6.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/ptyprocess/README2
-rw-r--r--python/ptyprocess/ptyprocess.SlackBuild8
-rw-r--r--python/ptyprocess/ptyprocess.info6
3 files changed, 11 insertions, 5 deletions
diff --git a/python/ptyprocess/README b/python/ptyprocess/README
index e80b0e9429..3891591654 100644
--- a/python/ptyprocess/README
+++ b/python/ptyprocess/README
@@ -6,3 +6,5 @@ Sometimes, piping stdin and stdout is not enough. There might be
a password prompt that doesn’t read from stdin, output that changes
when it’s going to a pipe rather than a terminal, or curses-style
interfaces that rely on a terminal.
+
+NOTE: python3 support will be added if python3 is installed.
diff --git a/python/ptyprocess/ptyprocess.SlackBuild b/python/ptyprocess/ptyprocess.SlackBuild
index df1ddda2d5..1a6b6ecac1 100644
--- a/python/ptyprocess/ptyprocess.SlackBuild
+++ b/python/ptyprocess/ptyprocess.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ptyprocess
-# Copyright 2016-2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2016-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ptyprocess
-VERSION=${VERSION:-0.5.2}
+VERSION=${VERSION:-0.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/ptyprocess/ptyprocess.info b/python/ptyprocess/ptyprocess.info
index 3d1c8efd38..50670da7a8 100644
--- a/python/ptyprocess/ptyprocess.info
+++ b/python/ptyprocess/ptyprocess.info
@@ -1,8 +1,8 @@
PRGNAM="ptyprocess"
-VERSION="0.5.2"
+VERSION="0.6.0"
HOMEPAGE="https://pypi.python.org/pypi/ptyprocess"
-DOWNLOAD="https://pypi.python.org/packages/51/83/5d07dc35534640b06f9d9f1a1d2bc2513fb9cc7595a1b0e28ae5477056ce/ptyprocess-0.5.2.tar.gz"
-MD5SUM="d3b8febae1b8c53b054bd818d0bb8665"
+DOWNLOAD="https://files.pythonhosted.org/packages/7d/2d/e4b8733cf79b7309d84c9081a4ab558c89d8c89da5961bf4ddb050ca1ce0/ptyprocess-0.6.0.tar.gz"
+MD5SUM="37402d69f3b50913d4d483587bffad8f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""